Opened 3 years ago

Last modified 2 years ago

#16188 reopened enhancement

TorButton Cookie Dialog is Useful, Please Restore It!

Reported by: starlight Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-torbutton, tbb-usability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I find the TorButton Cookie dialog very
useful for protecting one or two cookies
within a single browsing session and then
erasing the (potentially dozens) of junk
cookies that are often deposited by
a tangential search for information.

Please restore this excellent feature!

I read bug 14632 and do not understand
the point. Don't want to enable
cookie persistence (can't figure out
where to do it anyway) and find the
dialog terrifically useful regardless.

TorButton version 1.9.2.3
Linux-64 build

Child Tickets

Change History (3)

comment:1 in reply to:  description Changed 3 years ago by gk

Component: TorbuttonTor Browser
Keywords: tbb-torbutton tbb-usability added
Owner: set to tbb-team
Priority: majornormal
Type: defectenhancement

Replying to starlight:

I find the TorButton Cookie dialog very
useful for protecting one or two cookies
within a single browsing session and then
erasing the (potentially dozens) of junk
cookies that are often deposited by
a tangential search for information.

Please restore this excellent feature!

We do that once it is working again. The problem is the underlying bug #10353 which is actually a Mozilla one: the cookie dialog is not working in Private Browsing Mode which is not easy to fix.

I'll leave this ticket open for the actual work to be done once the #10353 got fixed.

comment:2 Changed 2 years ago by starlight

Resolution: fixed
Severity: Normal
Status: newclosed

This issue appears to be resolved as the "Cookie Protections" action again appears on the TorButton drop-down as-of Browser 5.5. Perhaps the ticket referenced by gk in comment 1 above should also be closed as well: #10353

comment:3 Changed 2 years ago by bugzilla

Resolution: fixed
Status: closedreopened

Nothing on 6.0a2

unless the user selects to enable history.

Bug 823941

Last edited 2 years ago by bugzilla (previous) (diff)
Note: See TracTickets for help on using tickets.