Opened 8 years ago

Closed 3 weeks ago

#1620 closed defect (worksforme)

Cross-site HTTPS links cause errors when TorButton is used with NoScript.

Reported by: katmagic Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When TorButton and NoScript are both being used, there is a delay of several seconds between opening a link from an HTTPS site to a different HTTPS site and the browser reacting in any fashion.

Child Tickets

Attachments (1)

noscript_configration (9.7 KB) - added by katmagic 8 years ago.
katmagic's NoScript configuration

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by mikeperry

Are you using any other addons, such as https-everywhere and/or RequestPolicy? There is a known conflict between those two that behaves very similar to this.

comment:2 in reply to:  1 Changed 8 years ago by katmagic

Replying to mikeperry:

Are you using any other addons, such as https-everywhere and/or RequestPolicy? There is a known conflict between those two that behaves very similar to this.

I am, but I disabled them while testing this bug.

comment:3 Changed 8 years ago by mikeperry

Resolution: duplicate
Status: newclosed

After talking to katmagic on irc, it sounds like we can't repo this without RP+https-everywhere enabled. Dupping it to #1574.

comment:4 Changed 8 years ago by mikeperry

Resolution: duplicate
Status: closedreopened

comment:5 Changed 8 years ago by katmagic

After further testing, it seems that this bug only appears on the first attempt at access to a sub-domain. If a URL is passed to Firefox on the command line, then a blank tab is opened but does not appear to load prior to the delay. This issue occurs with only NoScript and TorButton enabled.

Changed 8 years ago by katmagic

Attachment: noscript_configration added

katmagic's NoScript configuration

comment:6 Changed 8 years ago by mikeperry

Priority: normalmajor

comment:7 Changed 6 years ago by mikeperry

Owner: mikeperry deleted
Status: reopenedassigned

Does this still happen? I've never noticed it in TBB.

comment:8 Changed 2 years ago by bugzilla

Component: TorbuttonTor Browser
Severity: Normal
Version: Torbutton: 1.2.5

comment:9 Changed 7 months ago by teor

Status: assignednew

Mark all tickets that are assigned to nobody as "new".

comment:10 Changed 4 weeks ago by cypherpunks

Owner: set to tbb-team
Status: newassigned

comment:11 Changed 3 weeks ago by gk

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.