Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1625 closed defect (duplicate)

INFO log level of vidalia failing to establish a tor circuit on no bridge using Etisalat Nigeria

Reported by: Ifeanyi Owned by: phobos
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Jun 29 22:55:41.296 [Info] connection_ap_make_link(): Making internal direct tunnel to [scrubbed]:443 ...
Jun 29 22:55:41.296 [Info] onion_pick_cpath_exit(): Using requested exit node '7BE683E65D48141321C5ED92F075C55364AC7123'
Jun 29 22:55:41.296 [Info] circuit_handle_first_hop(): Next router is [scrubbed]: Not connected. Connecting.
Jun 29 22:55:41.296 [Info] connection_ap_make_link(): ... application connection created and linked.
Jun 29 22:55:41.296 [Info] directory_send_command(): Downloading consensus from 193.23.244.244:443 using /tor/status-vote/current/consensus.z
Jun 29 22:55:41.296 [Info] _connection_free(): Freeing linked Directory connection [client reading] with 0 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:41.296 [Info] connection_edge_process_inbuf(): data from edge while in 'waiting for circuit' state. Leaving it on buffer.
Jun 29 22:55:41.296 [Info] connection_edge_process_inbuf(): data from edge while in 'waiting for circuit' state. Leaving it on buffer.
Jun 29 22:55:42.688 [Info] connection_or_read_proxy_response(): HTTPS connect to '193.23.244.244' successful! (200 "Connection established") Starting TLS.
Jun 29 22:55:49.278 [Info] command_process_versions_cell(): Negotiated version 2 with [scrubbed]:443; sending NETINFO.
Jun 29 22:55:49.288 [Info] circuit_send_next_onion_skin(): First hop: finished sending CREATE_FAST cell to '<unnamed>'
Jun 29 22:55:49.288 [Info] command_process_netinfo_cell(): Got good NETINFO cell from [scrubbed]:443; OR connection is now open, using protocol version 2
Jun 29 22:55:58.842 [Info] circuit_n_conn_done(): or_conn failed. Closing circ.
Jun 29 22:55:58.842 [Info] connection_ap_fail_onehop(): Closing one-hop stream to '$0000000000000000000000000000000000000000/92.254.24.211' because the OR conn just failed.
Jun 29 22:55:58.842 [Info] _connection_free(): Freeing linked Socks connection [waiting for circuit] with 65 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.842 [Info] connection_dir_client_reached_eof(): 'fetch' response not all here, but we're at eof. Closing.
Jun 29 22:55:58.842 [Info] connection_dir_request_failed(): Giving up on directory server at '92.254.24.211'; retrying
Jun 29 22:55:58.842 [Info] _connection_free(): Freeing linked Directory connection [client reading] with 0 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.932 [Info] circuit_n_conn_done(): or_conn failed. Closing circ.
Jun 29 22:55:58.932 [Info] connection_ap_fail_onehop(): Closing one-hop stream to '$0000000000000000000000000000000000000000/202.60.233.93' because the OR conn just failed.
Jun 29 22:55:58.942 [Info] _connection_free(): Freeing linked Socks connection [waiting for circuit] with 66 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.942 [Info] circuit_n_conn_done(): or_conn failed. Closing circ.
Jun 29 22:55:58.942 [Info] connection_ap_fail_onehop(): Closing one-hop stream to '$0000000000000000000000000000000000000000/24.116.150.114' because the OR conn just failed.
Jun 29 22:55:58.942 [Info] _connection_free(): Freeing linked Socks connection [waiting for circuit] with 67 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.952 [Info] circuit_n_conn_done(): or_conn failed. Closing circ.
Jun 29 22:55:58.952 [Info] connection_ap_fail_onehop(): Closing one-hop stream to '$0000000000000000000000000000000000000000/94.134.173.240' because the OR conn just failed.
Jun 29 22:55:58.952 [Info] _connection_free(): Freeing linked Socks connection [waiting for circuit] with 66 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.952 [Info] circuit_n_conn_done(): or_conn failed. Closing circ.
Jun 29 22:55:58.952 [Info] connection_ap_fail_onehop(): Closing one-hop stream to '$0000000000000000000000000000000000000000/94.134.166.207' because the OR conn just failed.
Jun 29 22:55:58.952 [Info] _connection_free(): Freeing linked Socks connection [waiting for circuit] with 66 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.952 [Info] connection_dir_client_reached_eof(): 'fetch' response not all here, but we're at eof. Closing.
Jun 29 22:55:58.952 [Info] connection_dir_request_failed(): Giving up on directory server at '202.60.233.93'; retrying
Jun 29 22:55:58.952 [Info] _connection_free(): Freeing linked Directory connection [client reading] with 0 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.952 [Info] connection_dir_client_reached_eof(): 'fetch' response not all here, but we're at eof. Closing.
Jun 29 22:55:58.952 [Info] connection_dir_request_failed(): Giving up on directory server at '24.116.150.114'; retrying
Jun 29 22:55:58.952 [Info] _connection_free(): Freeing linked Directory connection [client reading] with 0 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.952 [Info] connection_dir_client_reached_eof(): 'fetch' response not all here, but we're at eof. Closing.
Jun 29 22:55:58.952 [Info] connection_dir_request_failed(): Giving up on directory server at '94.134.173.240'; retrying
Jun 29 22:55:58.952 [Info] _connection_free(): Freeing linked Directory connection [client reading] with 0 bytes on inbuf, 0 on outbuf.
Jun 29 22:55:58.952 [Info] connection_dir_client_reached_eof(): 'fetch' response not all here, but we're at eof. Closing.
Jun 29 22:55:58.952 [Info] connection_dir_request_failed(): Giving up on directory server at '94.134.166.207'; retrying
Jun 29 22:55:58.952 [Info] _connection_free(): Freeing linked Directory connection [client reading] with 0 bytes on inbuf, 0 on outbuf.
Jun 29 22:56:11.189 [Info] circuit_expire_building(): Abandoning circ 193.23.244.244:443:8788 (state 0:doing handshakes, purpose 5)
Jun 29 22:56:11.189 [Info] exit circ (length 1, exit 7BE683E65D48141321C5ED92F075C55364AC7123): $7BE683E65D48141321C5ED92F075C55364AC7123(waiting for keys)
Jun 29 22:56:11.189 [Info] circuit_build_failed(): Our circuit failed to get a response from the first hop (193.23.244.244:443). I'm going to try to rotate to a better connection.
Jun 29 22:56:11.189 [Info] connection_ap_fail_onehop(): Closing one-hop stream to '$7BE683E65D48141321C5ED92F075C55364AC7123/193.23.244.244' because the OR conn just failed.
Jun 29 22:56:11.189 [Info] _connection_free(): Freeing linked Socks connection [waiting for circuit] with 79 bytes on inbuf, 0 on outbuf.
Jun 29 22:56:11.189 [Info] connection_dir_client_reached_eof(): 'fetch' response not all here, but we're at eof. Closing.
Jun 29 22:56:11.189 [Info] _connection_free(): Freeing linked Directory connection [client reading] with 0 bytes on inbuf, 0 on outbuf.
Jun 29 22:56:12.191 [Info] run_connection_housekeeping(): Expiring non-used OR connection to fd 1684 (193.23.244.244:443) [Too old].

Child Tickets

Change History (4)

comment:1 Changed 9 years ago by erinn

Component: TracTor - Tor client

Reassigning to Tor Client, but it seems to be a dupe of #1628 and #1645.

comment:2 Changed 9 years ago by phobos

Owner: set to phobos
Priority: blockernormal
Status: newassigned

Can you send the whole log from start to finish?

comment:3 Changed 9 years ago by phobos

Resolution: duplicate
Status: assignedclosed

moving to #1645 since it seems the issues are the same.

comment:4 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.