Opened 4 years ago

Closed 2 years ago

#16258 closed defect (wontfix)

Add "libssl-dev" and "C compiler" to bwauth dependencies

Reported by: mrphs Owned by: aagbsn
Priority: Medium Milestone:
Component: Core Tor/Torflow Version:
Severity: Blocker Keywords: bwauth
Cc: isis, mikeperry Actual Points:
Parent ID: #24088 Points:
Reviewer: Sponsor:

Description

I just ran the new bwauth setup on a brand new debian machine out of curiosity, and realized it tries to build tor from git and misses these two dependencies.

I just added it to the setup.sh script and attached a patch. feel free to edit/improve if necessary.

Child Tickets

Attachments (1)

0001-add-build-essential-and-libssl-dev-to-dependencies.patch (1.0 KB) - added by mrphs 4 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 4 years ago by mrphs

Status: newneeds_review

comment:2 Changed 2 years ago by teor

Parent ID: #24088
Resolution: wontfix
Severity: Blocker
Status: needs_reviewclosed

In #24088, we will remove the setup script instead. It's just too fragile.

Note: See TracTickets for help on using tickets.