Opened 4 years ago

Closed 12 months ago

#16302 closed defect (not a bug)

Getting further away from a domain-wide distribution of torbrowser, now if you delete tor launcher extension, tor button won't allow you to specify network settings....

Reported by: johnakabean Owned by:
Priority: Medium Milestone:
Component: Applications/Torbutton Version:
Severity: Normal Keywords: tor browser proxy settings, tor browser, proxy settings, tor button
Cc: johnakabean Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In another ticket?, along with talking with devs, I spoke of how, at the request of users, we was trying to deploy TorBrowser since we don't allow employees to execute any .exe.

The dev's (unknown) were supportive of fixing the issue but now there is another issue that may or may not be fixed when torbutton gets fixed, for the other addons issue encounterred.

When you delete torlauncher extension from the default pref folder, since we run a centralized, redundant cluster of tor.exe servers, tor button will not let you specify the socks & http(s) proxies. If you click the tor button uhhh button :) and select Tor Network Settings, nothing appears or pops up.

I haven't confirmed this is from removing tor launcher extension but, since no one else has reported it, I just assume.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by johnakabean

Cc: johnakabean added

THe other ticket that the wiki failed to link right: (it added /wiki to the path during parsing)

https://trac.torproject.org/projects/tor/ticket/14795

Last edited 4 years ago by johnakabean (previous) (diff)

comment:2 Changed 3 years ago by e.ex.exi.exit

Priority: ImmediateMedium
Severity: Normal
  1. The problem persists for torbutton 1.9.5.4 (bundled with torbrowser 6.0.1) for linux: Deleting the tor-launcher extension makes the torbutton network settings unavailable. Confusingly, you can change the network settings at

Edit->Preferences->Advanced->Network->Configure how Tor Browser connects to the Internet,

although it is stated on that form: "Disable Tor button to change these settings" (with a link to a more verbose explanation why you allegedly can not change the network settings here)."

  1. I run the tor browser with transparent proxying, and disabling the tor launcher is a necessary precondition for this configuration (runnnng tor over tor does not work in my configuration, and should be disabled anyway).

comment:3 Changed 12 months ago by gk

Resolution: not a bug
Status: newclosed
Version: Torbutton: 1.4.4.1

The feature behind that menu item is provided by Tor Launcher even if it shows up in the Torbutton menu. Thus, you need to have Tor Launcher enabled.

Note: See TracTickets for help on using tickets.