Opened 5 years ago

Closed 4 years ago

#16309 closed defect (not a bug)

Bug: Assertion node && node->ri == ri failed in nodelist_assert_ok

Reported by: t3mpo Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version: Tor: 0.2.5.12
Severity: Keywords: nodelist assert 025-backport 026-backport assertion
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

tor log:
Jun 08 01:16:31.000 [err] Bug: Assertion node && node->ri == ri failed in nodelist_assert_ok at ../src/or/nodelist.c:433. Stack trace:
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(log_backtrace+0x52) [0xb7707782]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(tor_assertion_failed_+0x94) [0xb7713bc4]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(nodelist_assert_ok+0x107) [0xb762fa37]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(nodelist_set_consensus+0x24d) [0xb763186d]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(networkstatus_set_current_consensus+0x993) [0xb762deb3]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(+0xde89e) [0xb76da89e]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(connection_dir_reached_eof+0x30) [0xb76dbf30]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(+0xc08ff) [0xb76bc8ff]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(+0x27669) [0xb7623669]
Jun 08 01:16:31.000 [err] Bug: /usr/lib/i386-linux-gnu/libevent-2.0.so.5(event_base_loop+0x73d) [0xb752236d]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(do_main_loop+0x19d) [0xb7624e1d]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(tor_main+0x1625) [0xb7627b05]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(main+0x35) [0xb7621345]
Jun 08 01:16:31.000 [err] Bug: /lib/i386-linux-gnu/i686/cmov/libc.so.6(libc_start_main+0xf3) [0xb7106a63]
Jun 08 01:16:31.000 [err] Bug: /usr/bin/tor(+0x25394) [0xb7621394]

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by t3mpo

# uname -a
Linux rocket 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) i686 GNU/Linux

comment:2 Changed 5 years ago by t3mpo

# cat /etc/tor/torrc
ORPort 110

SocksPort 9050
SocksPort 10.10.100.254:9050
SocksPolicy accept 10.10.100.0/24
SocksPolicy reject *

ControlPort 9051
HashedControlPassword 16:xxxxxxxxxxxxxxxxxx
CookieAuthentication 1

Nickname 123

RelayBandwidthRate 4000 KB
RelayBandwidthBurst 5000 KB

ExitPolicy reject *:*

RunAsDaemon 1

comment:3 Changed 5 years ago by nickm

Keywords: 025-backport 026-backport assertion added
Milestone: Tor: 0.2.7.x-final

comment:4 Changed 4 years ago by t3mpo

Resolution: not a bug
Status: newclosed

Problem solved, i have hardware error with motherboad "asus p5gv-mx", replaced it, and all is well.

Note: See TracTickets for help on using tickets.