Opened 5 years ago

Closed 5 years ago

#16315 closed defect (fixed)

New media queries in picture element may need alteration

Reported by: mikeperry Owned by: arthuredelstein
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: ff38-esr, tbb-fingerprinting-resolution, TorBrowserTeam201506R, GeorgKoppen201506R
Cc: gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The picture element added in Firefox 33 has the ability to perform media queries: https://developer.mozilla.org/en-US/docs/Web/HTML/Element/picture.

We should verify that these media queries use the content window resolution, rather than the desktop resolution.

Child Tickets

Change History (8)

comment:1 Changed 5 years ago by gk

Cc: gk added

comment:2 Changed 5 years ago by arthuredelstein

Owner: changed from tbb-team to arthuredelstein
Status: newassigned

comment:3 Changed 5 years ago by arthuredelstein

Keywords: TorBrowser201506R added
Status: assignedneeds_review

Here is a patch containing regression tests that confirm that media queries in picture elements are correctly spoofed. This spoofing happens because of our pre-existing patch for #2875:

https://github.com/arthuredelstein/tor-browser/commit/16315

comment:4 Changed 5 years ago by arthuredelstein

Keywords: TorBrowserTeam201506R added; TorBrowser201506R removed

comment:5 Changed 5 years ago by gk

Keywords: GeorgKoppen201506R added

Looks good to me.

comment:6 Changed 5 years ago by mikeperry

As I asked on IRC, are we sure this new tests actually fails on FF38 without our media query alteration patch?

comment:7 in reply to:  6 Changed 5 years ago by arthuredelstein

Replying to mikeperry:

As I asked on IRC, are we sure this new tests actually fails on FF38 without our media query alteration patch?

Good question. I reverted #2875 and three of the picture element tests failed. The rest did not fail, because their default values happen to be the same as our spoofing values.

Last edited 5 years ago by arthuredelstein (previous) (diff)

comment:8 Changed 5 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Commit 452f870c8dff8089f759c9052960ad7fc73866a0 has the fix.

Note: See TracTickets for help on using tickets.