Opened 4 years ago

Closed 3 years ago

#16324 closed defect (not a bug)

Focusing the search bar is already creating/using a catchall circuit

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-linkability
Cc: bugzilla Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If one focuses the search bar something like

Torbutton INFO: tor SOCKS isolation catchall: https://search.disconnect.me/searchTerms/search?ses=Google&location_option=US via --unknown--:2

is visible in the log. This gets worse with ESR 38 (see: https://bugzilla.mozilla.org/show_bug.cgi?id=1006103) where the search bar on about:newtab and about:home is using speculative connect as well. The argument that this speeds up the search process is not really valid in the Tor case I think. Rather, this leaks information and uses the Tor network which we should avoid.

Child Tickets

Change History (9)

comment:1 Changed 4 years ago by gk

Cc: bugzilla added
Severity: Normal

#18532 is a duplicate.

comment:2 Changed 3 years ago by bugzilla

[03-22 17:03:31] Torbutton INFO: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [mozIThirdPartyUtil.getFirstPartyURIFromChannel]

and then search is going through catchall.
In about:home plus:

[03-22 17:09:02] Torbutton INFO: tor SOCKS: https://snippets.cdn.mozilla.net/4/Firefox/38.7.1/20000101000000/WINNT_x86-gcc3/en-US/alpha/Windows_NT%206.1/default/default/ via --NoFirstPartyHost-about-home--:0
InvalidStateError aboutHome.js:228:0
InvalidStateError aboutHome.js:234:0

Should FF return URI for the search bar (file them a bug) or it's another issue?

comment:3 Changed 3 years ago by bugzilla

The same situation is with #16747: due to mozbug favicons are loaded twice, but one of them doesn't belong to content, so NS_ERROR_ILLEGAL_VALUE and then - through catchall...
But, as proposed in #18122, if every new tab has its own circuit (local "catchall") then the problem of linkability will be solved.

comment:4 Changed 3 years ago by gk

#19262 is a duplicate.

comment:5 Changed 3 years ago by gk

Resolution: not a bug
Status: newclosed

We use a proxy and it turns out speculative connects are not issues if that's the case. This is not a bug. For a more detailed analysis, see #18762.

comment:6 Changed 3 years ago by bugzilla

Keywords: tbb-linkability added
Resolution: not a bug
Status: closedreopened
Summary: Focusing the search bar is already creating/using a circuitFocusing the search bar is already creating/using a catchall circuit

TBB 6.5a2, no favicons, new tab, focus to the search bar and

getFirstPartyURI failed for https://search.disconnect.me/searchTerms/search?ses=Google&location_option=US&source=tor: 0x80070057

then messages from comment:2 and the description.
Why not a bug?

comment:7 Changed 3 years ago by gk

Resolution: not a bug
Status: reopenedclosed

As I said, see #18762, in particular comment:3:ticket:18762.

comment:8 Changed 3 years ago by bugzilla

Resolution: not a bug
Status: closedreopened

So, Arthur creates a new ticket for "a favicon is displayed in the searchbar popup which causes a connection over the catchall circuit" and you closes the ticket about the same for the searchbar!
What the hell is going on here?

comment:9 Changed 3 years ago by gk

Resolution: not a bug
Status: reopenedclosed

Nothing special. I am closing this bug as the issue *I* had and which was the reason why *I* created this bug is a non-issue. The other one Arthur has found is dealt with in #19741.

Note: See TracTickets for help on using tickets.