Opened 4 years ago

Closed 4 years ago

#16331 closed defect (not a bug)

BridgeDB is failing to parse extrainfo descriptors because bridges are running the ed25519 code

Reported by: isis Owned by: isis
Priority: Very High Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords: bridgedb-parsers
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

BridgeDB is failing to parse descriptors because its version of Stem (1.3.0) can't parse the ed25519 code from prop#220 and prop#228.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by atagar

Hi Isis. You just filed #16330 - this sounds like a duplicate?

Regardless, simply upgrading to use the latest tip of stem's git repo will do the trick.

comment:2 in reply to:  1 Changed 4 years ago by isis

Replying to atagar:

Hi Isis. You just filed #16330 - this sounds like a duplicate?

Regardless, simply upgrading to use the latest tip of stem's git repo will do the trick.


I'm sorry, and you're correct, atagar. I completely forgot that the prop#228 code added an additional extrainfo-digest field… previously I was only considering the prop#220 changes, and thought the issues of some funny additional extrainfo-digest field, and ed25519 keys/certs, were separate. But you're right that they're the same problem, and that it's already fixed in Stem-1.4.1. Sorry for the noise!

comment:3 Changed 4 years ago by isis

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.