Opened 4 years ago

Closed 19 months ago

Last modified 18 months ago

#16333 closed task (fixed)

Make sure IndexedDB is disabled from worker code

Reported by: gk Owned by: gk
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff52-esr, tbb-linkability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

IndexedDB is available to WebWorkers. We should verify it remains disabled. https://bugzilla.mozilla.org/show_bug.cgi?id=701634 has the implementation details.

Child Tickets

Change History (18)

comment:1 Changed 4 years ago by mikeperry

Keywords: tbb-5.0a TorBrowserTeam201507 added

Tag the set of things we should have implemented before a full 5.0 launch, and add them to the July radar.

comment:2 Changed 4 years ago by mikeperry

Keywords: TorBrowserTeam201508 added; TorBrowserTeam201507 removed

comment:3 Changed 4 years ago by gk

Owner: changed from tbb-team to gk
Status: newassigned

comment:4 Changed 4 years ago by mikeperry

Keywords: TorBrowserTeam201509 added; TorBrowserTeam201508 removed

Move remaining August tickets to September.

comment:5 Changed 4 years ago by gk

Keywords: GeorgKoppen201509 added

comment:6 Changed 4 years ago by gk

Keywords: TorBrowserTeam201510 added; TorBrowserTeam201509 removed

Moving Tor Browser tickets to October 2015.

comment:7 Changed 4 years ago by gk

Keywords: GeorgKoppen201510 added; GeorgKoppen201509 removed

Moving my tickets to October 2015

comment:8 Changed 4 years ago by gk

Keywords: TorBrowserTeam201511 added; TorBrowserTeam201510 removed

comment:9 Changed 4 years ago by gk

Keywords: GeorgKoppen201511 added; GeorgKoppen201510 removed

comment:10 Changed 4 years ago by mikeperry

Keywords: TorBrowserTeam201512 added; TorBrowserTeam201511 removed

comment:11 Changed 3 years ago by gk

Keywords: TorBrowserTeam201601 added; TorBrowserTeam201512 removed

Tickets for Jan 2016.

comment:12 Changed 3 years ago by gk

Keywords: GeorgKoppen201601 added; GeorgKoppen201511 removed

comment:13 Changed 2 years ago by gk

Keywords: ff52-esr added; ff38-esr tbb-5.0a TorBrowserTeam201601 GeorgKoppen201601 removed
Severity: Normal

comment:14 Changed 20 months ago by cypherpunks

Resolution: invalid
Status: assignedclosed

comment:15 Changed 20 months ago by gk

Resolution: invalid
Status: closedreopened

Please don't close random tickets, thanks.

comment:16 Changed 20 months ago by cypherpunks

???

comment:17 Changed 19 months ago by gk

Resolution: fixed
Status: reopenedclosed

It turns out IndexedDB from worker code was disabled when we set dom.indexedDB.enabled to false. However, we needed to enable it due to crashes we hit (see: #23745). That in turned caused IndexedDB to be enabled from worker code due to a bug in Firefox, see: https://bugzilla.mozilla.org/show_bug.cgi?id=1410106. This got fixed in ESR 52.5.2 which is included in Tor Browser 7.0.11 and 7.5a9.

comment:18 in reply to:  17 Changed 18 months ago by cypherpunks

Replying to gk:

It turns out IndexedDB from worker code was disabled when we set dom.indexedDB.enabled to false.

It turns out IDB was disabled when it was disabled. Heh. (This ticket is fixed :)

However, we needed to enable it due to crashes we hit (see: #23745).

Thus this ticked became invalid.

That in turned caused IndexedDB to be enabled from worker code due to a bug in Firefox,

It's a good feature, not a bug, and it's good that it's now enabled in Tor Browser, but

see: https://bugzilla.mozilla.org/show_bug.cgi?id=1410106.

for why it shouldn't be available from PB-related workers.

This got fixed in ESR 52.5.2 which is included in Tor Browser 7.0.11 and 7.5a9.

And what was fixed in this ticket?

Note: See TracTickets for help on using tickets.