Opened 4 years ago

Closed 4 years ago

#16365 closed defect (duplicate)

tor_assertion_failed_(): Bug: src/or/circuituse.c

Reported by: starlight Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.6.9
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hopefully attachments are useful.

More detail on request though
prefer to share unobfuscated
stack trace and core privately.

Child Tickets

Attachments (2)

messages-obfus.txt (1.9 KB) - added by starlight 4 years ago.
log messages
gdb-trace-obfus.txt (4.1 KB) - added by starlight 4 years ago.
stack trace

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by starlight

Attachment: messages-obfus.txt added

log messages

comment:1 Changed 4 years ago by starlight

May be related to or same as bug #15901
where a possible memory corruption
is caused by the crypto thread running
openssl copmiled LTO.

If the stack trace does not lead
to an obvious problem of another
kind possibly memory corrution
is the cause.

Am now eliminating the second thread.

comment:2 Changed 4 years ago by starlight

strange. . .setting

NumCPUs 1

does not appear to work. Still have
second thread burning 0.3 to 1.0%
CPU. Another bug?

comment:3 Changed 4 years ago by yawning

Resolution: duplicate
Status: newclosed

Duplicate of #16013

Changed 4 years ago by starlight

Attachment: gdb-trace-obfus.txt added

stack trace

Note: See TracTickets for help on using tickets.