Opened 4 years ago

Closed 4 years ago

#16371 closed enhancement (not a bug)

Use soft links to dependencies instead of hard links

Reported by: leeroy Owned by:
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords: build.xml dependencies
Cc: iwakeh Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

One thing I noticed when setting up a test Onionoo server was the use of hard links in build.xml. An improvement here would be to instead use the soft links created during installation. I don't imagine this would break anything since I'm using newer versions of many of those packages without any problems.

Child Tickets

Attachments (3)

0001-Use-soft-links-to-dependencies-instead-of-hard-links.patch (5.2 KB) - added by leeroy 4 years ago.
0001-Use-soft-links-to-dependencies.patch (5.2 KB) - added by leeroy 4 years ago.
0002-Use-soft-links-to-dependencies.patch (666 bytes) - added by leeroy 4 years ago.
Now also include support for xz tarball archives.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 4 years ago by leeroy

Status: newneeds_review

comment:2 Changed 4 years ago by karsten

Cc: iwakeh added
Status: needs_reviewneeds_information

Actually, we put in file names containing file names to be sure that we're using exactly these versions. I'm copying iwakeh who was involved in this decision.

comment:3 Changed 4 years ago by leeroy

That's what I thought. The documentation made no mention of placing holds on package updates so I just gave it a try. I might have gotten lucky.

comment:4 Changed 4 years ago by leeroy

I think the question that needs to be asked is, do you want to update the build file to reflect modern installs, or do you want to make it more generic? Either way build.xml needs to be updated. The patch tries to be more generic.

comment:5 Changed 4 years ago by leeroy

Parent ID: #16424

comment:6 Changed 4 years ago by leeroy

Status: needs_informationneeds_revision

comment:7 Changed 4 years ago by leeroy

Parent ID: #16424

Changed 4 years ago by leeroy

Changed 4 years ago by leeroy

Now also include support for xz tarball archives.

comment:8 Changed 4 years ago by leeroy

Status: needs_revisionneeds_review

comment:9 Changed 4 years ago by leeroy

Parent ID: #16612

comment:10 Changed 4 years ago by iwakeh

Parent ID: #16612

Parent removed, b/c it looks like a mistake.

comment:11 Changed 4 years ago by iwakeh

Resolution: not a bug
Status: needs_reviewclosed

Closed,b/c the version strings for dependencies were deliberately included in #13088.

Note: See TracTickets for help on using tickets.