Opened 4 years ago

Closed 3 years ago

#16376 closed defect (fixed)

Firefox bug - When I close Tor Browser, it clears clipboard.

Reported by: Ilya_SpongeBob Owned by:
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, ff45-esr-will-have
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Please add an option to turn of clearing clipboard on browser close.

Child Tickets

Change History (17)

comment:1 Changed 4 years ago by gk

Component: - Select a componentTor Browser
Keywords: tbb-usability added
Resolution: worksforme
Status: newclosed

Works for me: I can select a URL, copy it, close Tor Browser and paste the URL in a text file on Linux.

comment:2 Changed 4 years ago by Ilya_SpongeBob

Works for me: I can select a URL, copy it, close Tor Browser and paste the URL in a text file on Linux.

Open TorBrowser and go to some site. Select come text inside TorBroser window on this site (you can even copy Congratulations! from start page) and press Ctrl+C. Close TorBrowser. What do you see by pressing Ctrl+V?

Last edited 4 years ago by Ilya_SpongeBob (previous) (diff)

comment:3 Changed 4 years ago by Ilya_SpongeBob

Priority: normalmajor
Resolution: worksforme
Status: closedreopened

comment:4 Changed 4 years ago by teor

Ilya_SpongeBob, which operating system are you using?
OS X? Windows? Linux?

I see the behaviour you describe with Tor Browser 4.5.1 on OS X Yosemite 10.10.3. The clipboard is cleared after Tor Browser exits.

I'd suggest you paste whatever you want to paste before Tor Browser exits. Because clearing the OS X pasteboard(s) is a privacy feature. Otherwise, things that people have searched for on a page, or copied from a page, can turn up in other apps later on.

comment:5 Changed 4 years ago by teor

(OS X has Find and Drag Pasteboards, as well as the normal Copy & Paste Clipboard. All of them can leak private data if we're not careful.)

comment:6 in reply to:  2 Changed 4 years ago by gk

Resolution: worksforme
Status: reopenedclosed

Replying to Ilya_SpongeBob:

Works for me: I can select a URL, copy it, close Tor Browser and paste the URL in a text file on Linux.

Open TorBrowser and go to some site. Select come text inside TorBroser window on this site (you can even copy Congratulations! from start page) and press Ctrl+C. Close TorBrowser. What do you see by pressing Ctrl+V?

The text I selected and copied. So, yes, this is working for me on my Linux box.

comment:7 in reply to:  4 Changed 4 years ago by Ilya_SpongeBob

Replying to teor:

Ilya_SpongeBob, which operating system are you using?
OS X? Windows? Linux?

I see the behaviour you describe with Tor Browser 4.5.1 on OS X Yosemite 10.10.3. The clipboard is cleared after Tor Browser exits.

I'd suggest you paste whatever you want to paste before Tor Browser exits. Because clearing the OS X pasteboard(s) is a privacy feature. Otherwise, things that people have searched for on a page, or copied from a page, can turn up in other apps later on.

I'm using WinXP Pro SP3.

comment:8 in reply to:  5 Changed 4 years ago by Ilya_SpongeBob

Resolution: worksforme
Status: closedreopened

Replying to teor:

(OS X has Find and Drag Pasteboards, as well as the normal Copy & Paste Clipboard. All of them can leak private data if we're not careful.)

I know. I'm asking to add an option to switch this off. Default can be on.

comment:9 Changed 4 years ago by teor

Resolution: not a bug
Status: reopenedclosed

Ilya_SpongeBob, I don't think that's going to happen.

Instead, please paste whatever you want to paste before you close the app.
This resolves your issue without adding another feature to Tor Browser.

gk has already closed this ticket twice, which is a polite way of refusing your request.
I've provided you an explanation as to why the feature is the way it is, and a workaround.

Please stop reopening this ticket, as that is considered rude by some people.

Instead, if the feature is of vital importance to you, please consider making the changes yourself from the Tor Browser source code, or finding someone with the requisite skills to do it for you.

This is solely my opinion: given the obscure nature of the feature, and the ready availability of a workaround, you may find that offering a paid bounty is necessary to get the work done. You may also find it never gets merged into the Tor Browser master branch.

comment:10 Changed 4 years ago by teor

Alternately, you can install Linux and use the Linux version of Tor Browser, which, according to gk, has the copy and paste behaviour you want.

comment:11 Changed 4 years ago by Ilya_SpongeBob

Please stop reopening this ticket, as that is considered rude by some people.

gk has already closed this ticket twice

You have closed tichet because you have lied all is workding for you. This is really rude.

I've provided you an explanation as to why the feature is the way it is, and a workaround.

All you said is "pay me to implement the feature". You did not expain why you need money as project is free. You also did not explain why you cannot implement just a feature, which will be disabled by default (so lamers don't have to worry about).

0140873A  /$  83EC 2C       SUB ESP,2C
0140873D  |.  FF15 E4AF1303 CALL DWORD PTR DS:[<&KERNEL32.IsDebugger>; |[IsDebuggerPresent
01408743  |.  85C0          TEST EAX,EAX                             ; |
01408745  |.  74 4A         JE SHORT xul.01408791                    ; |
01408747  |.  C74424 10 001>MOV DWORD PTR SS:[ESP+10],1000           ; |
0140874F  |.  8B4424 30     MOV EAX,DWORD PTR SS:[ESP+30]            ; |
01408753  |.  894424 14     MOV DWORD PTR SS:[ESP+14],EAX            ; |
01408757  |.  FF15 ECAE1303 CALL DWORD PTR DS:[<&KERNEL32.GetCurrent>; |[GetCurrentThreadId
0140875D  |.  894424 18     MOV DWORD PTR SS:[ESP+18],EAX            ; |
01408761  |.  C74424 1C 000>MOV DWORD PTR SS:[ESP+1C],0              ; |
01408769  |.  8D4424 10     LEA EAX,DWORD PTR SS:[ESP+10]            ; |
0140876D  |.  894424 0C     MOV DWORD PTR SS:[ESP+C],EAX             ; |
01408771  |.  C74424 08 040>MOV DWORD PTR SS:[ESP+8],4               ; |
01408779  |.  C74424 04 000>MOV DWORD PTR SS:[ESP+4],0               ; |
01408781  |.  C70424 88136D>MOV DWORD PTR SS:[ESP],406D1388          ; |
01408788  |.  FF15 48B01303 CALL DWORD PTR DS:[<&KERNEL32.RaiseExcep>; \RaiseException
0140878E  |.  83EC 10       SUB ESP,10
01408791  |>  83C4 2C       ADD ESP,2C
01408794  \.  C3            RETN

First people must patch JE > JMP.

01D9EE18   .  807C24 2F 00  CMP BYTE PTR SS:[ESP+2F],0
01D9EE1D   .  74 07         JE SHORT xul.01D9EE26
01D9EE1F   .  EB 1A         JMP SHORT xul.01D9EE3B
01D9EE21   >  BB 00000000   MOV EBX,0
01D9EE26   >  8B4424 34     MOV EAX,DWORD PTR SS:[ESP+34]
01D9EE2A   .  85C0          TEST EAX,EAX
01D9EE2C   .  74 2A         JE SHORT xul.01D9EE58
01D9EE2E   .  8B10          MOV EDX,DWORD PTR DS:[EAX]
01D9EE30   .  890424        MOV DWORD PTR SS:[ESP],EAX
01D9EE33   .  FF52 08       CALL DWORD PTR DS:[EDX+8]
01D9EE36   .  83EC 04       SUB ESP,4
01D9EE39   .  EB 1D         JMP SHORT xul.01D9EE58
01D9EE3B   >  C70424 000000>MOV DWORD PTR SS:[ESP],0
01D9EE42   .  FF15 4CB41303 CALL DWORD PTR DS:[<&ole32.OleSetClipboa>;  ole32.OleSetClipboard

First line

CMP BYTE PTR SS:[ESP+2F],0

is something like option compare. You can modify next JE to JMP.

comment:12 in reply to:  11 Changed 4 years ago by teor

Replying to Ilya_SpongeBob:

Please stop reopening this ticket, as that is considered rude by some people.

gk has already closed this ticket twice

You have closed tichet because you have lied all is workding for you. This is really rude.

No, we've told you how it works on the platforms that we have access to (Linux, OS X), and the reasons that we are satisfied with that behaviour. I don't have access to Windows. So I can only assume that Windows works like OS X.

I've provided you an explanation as to why the feature is the way it is, and a workaround.

All you said is "pay me to implement the feature". You did not expain why you need money as project is free. You also did not explain why you cannot implement just a feature, which will be disabled by default (so lamers don't have to worry about).

I apologise for mentioning money. I regret that it led to a miscommunication. I did not intend to cause offense. It was only my opinion, and I said as much. I do not want money. I do not have the skills you require. I do not even have access to a Windows machine. And I am not familiar with the Tor Browser source code.

Please understand:

In a project supplied without cost, you can request a feature, and then the feature gets implemented if it fits the project's goals.

In a project supplied with source code, you can implement the feature yourself, or find someone to do it for you.

So here are your options:

  • Use Tor Browser on Windows as it is, and give up on having this feature
  • Use Tor Browser on Windows as it is, and paste before you exit the app
  • Use Tor Browser on Linux, which works the way you want it to work
  • Modify Tor Browser to work the way you want it to
  • Find a developer to modify Tor Browser for you

It is very unlikely that further posts on this ticket will convince a developer to make the changes you want.
Whichever option you choose, this ticket is not the place to make it happen.
So please stop posting.

comment:13 Changed 4 years ago by gk

Folks, calm down.

1) There is already the option to get that behavior you want on non-Linux platforms: just leave the private browsing mode (PBM). I guess that this is working even within the PBM on Linux is due to someone not caring about Linux when the original feature (clear clipboard when last PBM window got closed) got implemented.

2) This behavior will change when we base Tor Browser on ESR 38 which is happening in two weeks for the alpha and in eight weeks for the stable series as this feature got reverted in https://bugzilla.mozilla.org/show_bug.cgi?id=815952. Thus, this will be a non-issue in Tor Browser 5.0

comment:14 Changed 4 years ago by teor

Sorry, gk, Ilya_SpongeBob, I got caught up in the issue.
I didn't know enough about what I was talking about to be truly helpful.

comment:15 Changed 4 years ago by Ilya_SpongeBob

There is already the option to get that behavior you want on non-Linux platforms: just leave the private browsing mode (PBM)

How to access this option? I cannot find "private browsing mode". It's much more easier to patch your application than write a tickets:
https://ia601505.us.archive.org/14/items/TorbrowserBugtracker/xul.zip
password : 12345678

And never add anti-debugging APIs. It makes me angry.

Last edited 4 years ago by Ilya_SpongeBob (previous) (diff)

comment:16 Changed 3 years ago by bugzilla

Resolution: not a bug
Severity: Normal
Status: closedreopened

Oh, men, it's not a ghost! It's a Mozilla crap. (not a bug deleted)
How can it still be present? They forgot about WINXP branch (?)

comment:17 Changed 3 years ago by bugzilla

Keywords: ff45-esr-will-have added
Resolution: fixed
Status: reopenedclosed
Summary: When I close TorBrowser 4.5.1, it clears clipboard.Firefox bug - When I close Tor Browser, it clears clipboard.

Mysteriously fixed by FF45ESR (as mysteriously wasn't fixed by FF38ESR).
Users feel the difference: https://blog.torproject.org/blog/tor-browser-602-released#comment-189604

Note: See TracTickets for help on using tickets.