Opened 2 years ago

Closed 2 years ago

#16419 closed defect (not a bug)

TorBirdy fails to set timezone to UTC after upgrading from Fedora 20 to Fedora 21

Reported by: cypherpunxs Owned by: ioerror
Priority: Immediate Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While running Fedora 20, outbound email headers look as expected (UTC):

Date: ..... +0000

after upgrading/changing to Fedora 21:

Date: .... +<actual offset>

(changing back to Fedora 20 makes the problem disappear again).

Underlying platform is Qubes OS. Using the default VM templates provided by Qubes OS (but I do not know whether that is in any way relevant. I did not test on native Fedora installations).

Thunderbird Version did not change and is: 31.7.0

TorBirdy Version (also unchanged): 0.1.4

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by cypherpunxs

Unable to reproduce this on native Fedora 21 (not using Qubes OS templates).

comment:2 Changed 2 years ago by cypherpunxs

Some more debugging:
Components.classes["@mozilla.org/process/environment;1"].getService(Components.interfaces.nsIEnvironment).get('TZ')
gives me 'UTC' on both cases (Fedora 20 and Fedora 21), but
Date()
returns a UTC timestamp on Fedora 20 and a non-UTC timestamp on Fedora 21.

What else could I look at?

comment:3 Changed 2 years ago by cypherpunxs

Resolution: not a bug
Status: newclosed

This problem affects torbirdy but is not limited to it.

on Fedora 20's shell (where things work):
-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠
$ date
<local timestamp>

$ TZ=UTC date
<*UTC* timestamp>

on Fedora 21's shell:
-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠-⁠
$ date
<local timestamp>

$ TZ=UTC date
<*local* timestamp>

so TZ gets ignored completely.

So there is probably nothing that torbirdy can change.

Note: See TracTickets for help on using tickets.