Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#16437 closed defect (duplicate)

[warn] Failed to find node for hop 0 of our path. Discarding this circuit.

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs
Cc: arma Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am using a vanilla bridge and my torrc looks like this.

UseBridges 1
Bridge xxx.xxx.xxx.xxx:443 AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA 
ReachableAddresses accept *:80, accept *:443, reject *:*
ReachableAddresses reject *:*

When using the bridge I sometimes get a flood of the following message.

[info] circuit_get_open_circ_or_launch(): No safe circuit (purpose 5) ready for edge connection; delaying.
[info] onion_pick_cpath_exit(): Using requested exit node '$03A2F59C7415951F16EF5F0FA7A266E63656DFE6~henriwatsonpnj0 at 162.218.233.43'
[info] compute_weighted_bandwidths(): Empty routerlist passed in to consensus weight node selection for rule weight as guard
[warn] Failed to find node for hop 0 of our path. Discarding this circuit.
[info] onion_populate_cpath(): Generating cpath hop failed.

And as far as I can tell even with that message flood, the bridge keeps working fine creating other streams and circuits and working as normal.

Child Tickets

Change History (9)

comment:1 Changed 4 years ago by cypherpunks

Another example.

[info] onion_pick_cpath_exit(): Using requested exit node '$ADEBB2D2EF73271EEFCE855E49EDD627BE6ACE49~Unnamed at 162.218.118.12'
[info] compute_weighted_bandwidths(): Empty routerlist passed in to consensus weight node selection for rule weight as guard
[warn] Failed to find node for hop 0 of our path. Discarding this circuit.
[info] onion_populate_cpath(): Generating cpath hop failed.

I'll post any other relay if I see any.

comment:2 Changed 4 years ago by cypherpunks

Ah I see what is happening here. The bridge that I'm using also starts with 162.218.*.*

https://atlas.torproject.org/#details/C52140B132361541653F28C50727D36DE262A652

comment:3 Changed 4 years ago by arma

Ah ha! That looks like #2998 then.

comment:4 Changed 4 years ago by cypherpunks

Hi arma, once again this is happening in the context of accessing some hidden services.

I don't understand why it is happening, I mean if those relays were picked because they were the hsdir of the service at the time, well tor had 5 other hsdirs to check for the information instead.

but, if those relays were picked by my client as RP to the hidden service, then that's a good candidate of a bug in tor.

Maybe what is happening is the hidden service is gone, and all the other 5 hsdirs were checked for the descriptor and it was just time for the 6th check? I don't know, i'm not too familiar with the mechanics of that.

Edit: Or maybe those relays were the Introduction Points of the services? But doesn't each service have 3 Introduction points or just one?

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:5 Changed 4 years ago by teor

Keywords: tor-hs added
Milestone: Tor: 0.2.???

comment:6 Changed 4 years ago by arma

Severity: Normal

I wonder if we should close as a duplicate of #2998?

comment:7 Changed 4 years ago by teor

Resolution: duplicate
Status: newclosed

comment:8 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:9 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.