Opened 4 years ago

Last modified 6 months ago

#16456 new defect

screen size fingerprint with findbar panel/bookmarks toolbar

Reported by: tmpAnon Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-fingerprinting-resolution
Cc: saint, gk, brade, mcs, twim, zorlaguzellikolmaz, righnaw, Dbryrtfbcbhgf Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello,
when we are opening findbar panel (ctrl + F hotkeys) screen size will changes.
You may see javascript properties:
height
width
availHeight
availWidth

You may fix this with css style like this:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

findbar {

position: fixed !important;
bottom: 0px !important;
left: 0px !important;
width: 100% !important;

}

.findbar-closebutton.close-icon {
/*

  • Do something with close findbar button */

}

Child Tickets

Change History (17)

comment:1 Changed 4 years ago by saint

Cc: saint added

comment:2 Changed 4 years ago by gk

Cc: gk added
Component: TorbuttonTor Browser
Keywords: tbb-fingerprinting-resolution added; findbar css screen size screen fingerprint removed
Owner: set to tbb-team

comment:3 Changed 4 years ago by mcs

Cc: brade mcs added

comment:4 Changed 4 years ago by klonido

Status: newneeds_information

Is this a problem with the UI, or are you saying that the change in window size when using the find bar has fingerprinting implications?

comment:5 in reply to:  4 Changed 4 years ago by gk

Status: needs_informationassigned

Replying to klonido:

Is this a problem with the UI, or are you saying that the change in window size when using the find bar has fingerprinting implications?

The latter.

comment:6 Changed 4 years ago by gk

Status: assignednew

comment:7 Changed 4 years ago by bugzilla

Severity: Normal

#17733 (Adjust windows size on adding of bookmarks toolbar) was closed as a duplicate of that.

Last edited 4 years ago by bugzilla (previous) (diff)

comment:8 Changed 4 years ago by bugzilla

Type: enhancementdefect

Let's track changes of resolution without warnings as defects.
Oh, it's a resurrection of #7562 (closed as not a bug. Why?).

Last edited 3 years ago by bugzilla (previous) (diff)

comment:9 Changed 4 years ago by gk

Summary: screen size fingerprint with findbar panelscreen size fingerprint with findbar panel/bookmarks toolbar

comment:10 Changed 4 years ago by gk

Cc: twim added

comment:11 Changed 4 years ago by bugzilla

#18046 is a duplicate.

comment:12 Changed 4 years ago by gk

Cc: zorlaguzellikolmaz added

comment:13 Changed 3 years ago by gk

Cc: righnaw added

#21163 is a duplicate.

comment:14 Changed 3 years ago by gk

Cc: Dbryrtfbcbhgf added

#21387 is a duplicate.

comment:15 Changed 3 years ago by gk

See #21409 when working on this ticket.

comment:16 Changed 3 years ago by mcs

Related to this ticket: as of Firefox 52 ESR, the toolbar will be opened automatically when a bookmark is added to the "Bookmarks Toolbar" folder. See: https://bugzilla.mozilla.org/show_bug.cgi?id=1219788

comment:17 Changed 6 months ago by Thorin

Close as dupe of #14429 ?

With RFP letterboxing (ESR68+), the inner window is changed with *almost* every conceivable way of screwing with chrome. So that mitigates manual resizing, toggling toolbars, app menu, sidebar, going full screen.

The only one that doesn't is the findbar, which is shown per tab. Not sure what the answer for that is.

Note: See TracTickets for help on using tickets.