Opened 3 years ago

Closed 12 months ago

Last modified 12 months ago

#16485 closed defect (fixed)

Firefox bug - Unrecognized storage name 'null' in about:cache URL

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, TorBrowserTeam201706R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Opening about:cache does not show any entries. The reason seems to be that Private is unchecked. Doing that and trying to update the cache is resulting in an error:

Unrecognized storage name 'null' in about:cache URL

This is actually a Mozilla bug as this happens in a vanilla Firefox as well. But now clicking on Back to overview does give us the cache entries as Private is checked.

Child Tickets

Change History (9)

comment:1 Changed 22 months ago by bugzilla

Severity: Normal

ff45-esr-will-have?

comment:2 in reply to:  description Changed 19 months ago by bugzilla

Summary: about:cache does not show anything in Tor Browser based on ESR 38Firefox bug - Unrecognized storage name 'null' in about:cache URL

Replying to gk:

Opening about:cache does not show any entries.

It's good. But not all entries are Private, even Anonymous ;)

The reason seems to be that Private is unchecked. Doing that and trying to update the cache is resulting in an error:

Unrecognized storage name 'null' in about:cache URL

That's because URL is about:cache?storage=null&context=p,. Update works if it's not disabled by NoScript.

This is actually a Mozilla bug as this happens in a vanilla Firefox as well. But now clicking on Back to overview does give us the cache entries as Private is checked.

Hmm, still an issue for ESR45, but not so easy reproducible.
STR was found for blocked by NoScript page: check Private, allow page and get about:cache?storage=null&context=.
So, it seems only users with weird NoScript config, like in TBB, are affected, because Mozilla knows nothing about it. But the only one ticket with "Unrecognized storage" is great: https://bugzilla.mozilla.org/show_bug.cgi?id=1074485.
As this ticket is about usability: about:cache is neither usable, nor reliable, e.g. bugs 469677, 633747, 927919, etc.

Last edited 19 months ago by bugzilla (previous) (diff)

comment:3 in reply to:  description ; Changed 12 months ago by cypherpunks

Replying to gk:

Doing that and trying to update the cache is resulting in an error:

Update button doesn't work now for higher sec levels.

comment:4 in reply to:  3 Changed 12 months ago by gk

Replying to cypherpunks:

Replying to gk:

Doing that and trying to update the cache is resulting in an error:

Update button doesn't work now for higher sec levels.

That's #22458.

comment:5 Changed 12 months ago by gk

Keywords: TorBrowserTeam201705R added
Status: newneeds_review

comment:6 Changed 12 months ago by gk

Keywords: TorBrowserTeam201706R added; TorBrowserTeam201705R removed

Moving review tickets to 201706

comment:7 Changed 12 months ago by mcs

r=brade, r=mcs
I have trouble making sense of what is displayed in about:cache, but this fix looks okay.

Is there a Firefox bug filed for this issue?

comment:8 in reply to:  7 ; Changed 12 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Replying to mcs:

r=brade, r=mcs
I have trouble making sense of what is displayed in about:cache, but this fix looks okay.

That's probably due to the interface not being particular intuitive or more on this page being broken. :)

Is there a Firefox bug filed for this issue?

Not yet, I plan to file one later and reference it in this ticket.

Applied to tor-browser-52.1.1esr-7.0-1 and tor-browser-52.1.0esr-7.0-2 (commit e1f39122d16e5cd69dd11732d8fb2faf5087fdd2 and 9607f989206d048c9905d1b19cedf9913750c6c7).

comment:9 in reply to:  8 Changed 12 months ago by gk

Replying to gk:

Replying to mcs:

r=brade, r=mcs
I have trouble making sense of what is displayed in about:cache, but this fix looks okay.

That's probably due to the interface not being particular intuitive or more on this page being broken. :)

Is there a Firefox bug filed for this issue?

Not yet, I plan to file one later and reference it in this ticket.

Now it is: https://bugzilla.mozilla.org/show_bug.cgi?id=1371263

Note: See TracTickets for help on using tickets.