Opened 4 years ago

Closed 2 years ago

Last modified 6 months ago

#16489 closed defect (fixed)

Accounts window UX is not so good

Reported by: lunar Owned by:
Priority: Medium Milestone:
Component: Archived/Tor Messenger Version:
Severity: Normal Keywords:
Cc: seanrose, tor@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by lunar)

This is probably more of an Instantbird issue, but I feel that the “Accounts” window is way too crowded. Right now, for only one account configured, I have 9 different buttons for one window. I've circled them in red to make them more visible:

Screenshot of the account window with buttons circled in red

Automatic connections warning

I'm not sure why I'm notified that I've disabled automatic connections. I have done nothing to it. It's a default Tor Messenger setting, right? So maybe this warning should simply be disabled. At least it needs to be rephrased.

Also, why is this warning displayed when all my accounts are currently connected?

The fact that it displays a “dismiss” cross so close to the window manager “close” cross is confusing. They look the same and are just blended on the same background. (This is GNOME 3.16.2.)

Account lines

Before negative criticisms, I want to say that I was happy about the interactions to authorize an unknown certificate. The blue underlined action was visible but not saying “you need to hit me at all cost”. We ought to see on more users, but for me it was a good tradeoff.

The “Connect”/“Disconnect” button seems appropriate. The others, not so much. I'm not going to edit the account properties every day once it's working, and I'm certainly not gonig to delete it just like that.

Both options, instead of a button, could probably be in the form of smaller actionable images. A gear wheel or something similar for “Properties” and a garbage bin for “Delete”.

For both of these actions I'm going to look for something to do it, so if there's small and I have to aim, that's fine. “Connect” should be obvious because I should not be required to think too much before talking to my peers.

I don't really understand why the “Sign-in on startup” is here instead of in the “Properties”. Is it really something that I want to change even more often than anything in the “Properties” window?

Delete

When you press delete, there's a “Do not ask next time” checkbox in the confirmation window. I think it's a misfeature and just add clutter. You always want confirmation before loosing contact with people.

New account

Adding a new account is probably not something that I'm going to do everyday. So maybe replacing the button by a smaller “plus sign” would also make the window less cluttered.

Close

Why is there a “Close” button in this window? It seems to be only for the “accounts” window. Why can't user rely on their window manager to do it?

Child Tickets

Attachments (1)

account-window-alpha3.png (23.2 KB) - added by lunar 4 years ago.
Screenshot of the account window with buttons circled in red

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by lunar

Attachment: account-window-alpha3.png added

Screenshot of the account window with buttons circled in red

comment:1 Changed 4 years ago by lunar

Description: modified (diff)

comment:2 Changed 4 years ago by aleth-instantbird

Thanks for the detailed feedback!

I'm not sure why I'm notified that I've disabled automatic connections. I have done nothing >to it. It's a default Tor Messenger setting, right? So maybe this warning should simply be >disabled. At least it needs to be rephrased.

The pref Tor messenger has flipped is accountsManager.notification.userDisabled. As the name says, the current code assumes that this is due to user action, so you should consider either modifying the code to provide an alternative pref/string for the case where it's disabled by default (please file a bug on bugzilla if so) or patch this in Tor messenger.

The point is that for Instantbird users, the account manager will not show up on startup by default (instead, the desired accounts will automatically connect), so if it does (because the pref was flipped) that requires some explanation.

Also, why is this warning displayed when all my accounts are currently connected?

I'm not sure what the steps to reproduce are for this. If the warning is still displayed if you open the account manager when the program is already running, then that sounds like a bug which should be filed. If it's just there because you never dismissed the warning in the window, that seems less of an issue.

The “Connect”/“Disconnect” button seems appropriate. The others, not so much. I'm not going
to edit the account properties every day once it's working, and I'm certainly not gonig to
delete it just like that.

I'm not sure you will have noticed based on your screenshot as you have only one account, but all the extra buttons only appear for the *selected* account, so the number of buttons isn't quite so excessive ;)

I don't really understand why the “Sign-in on startup” is here instead of in the
“Properties”. Is it really something that I want to change even more often than anything in
the “Properties” window?

For Tor messenger with automatic connections on startup disabled, it does seem this checkbox isn't useful. If you'd like to file a bug to hide it if an appropriate pref is set (see above), that would be OK.

Why is there a “Close” button in this window? It seems to be only for the “accounts”
window. Why can't user rely on their window manager to do it?

Afaik it's useful on Windows. It could be hidden on other OS. Filed as https://bugzilla.mozilla.org/show_bug.cgi?id=1187281

comment:3 Changed 4 years ago by arlolra

Cc: arlolra added

comment:4 Changed 4 years ago by aleth-instantbird

The pref Tor messenger has flipped is accountsManager.notification.userDisabled. As the
name says, the current code assumes that this is due to user action, so you should consider
either modifying the code to provide an alternative pref/string for the case where it's
disabled by default (please file a bug on bugzilla if so)

Filed as https://bugzilla.mozilla.org/show_bug.cgi?id=1188280

comment:5 Changed 3 years ago by arlolra

Cc: seanrose added; arlolra removed
Severity: Normal

Another vote for removing "Connect now" in #18236

comment:6 Changed 3 years ago by clokep

Cc: tor@… added

comment:7 Changed 2 years ago by arlolra

Thanks for the detailed report.

https://gitweb.torproject.org/tor-messenger-build.git/commit/?id=4f9934fae3244b99262d45ec8039e12ab0517926
was included in TM v0.1.0b4, which fixes the "Automatic connections warning" and removed the "Sign-in on startup" property.

That reduces a lot of clutter.

We should eventually fix https://bugzilla.mozilla.org/show_bug.cgi?id=1187281 as well.

comment:8 Changed 2 years ago by arlolra

Resolution: fixed
Status: newclosed

comment:10 Changed 6 months ago by traumschule

<+sukhe> hello. yes, I think it's fine to close the tickets. thanks for doing what we should done earlier :)

sad but true:
https://blog.torproject.org/sunsetting-tor-messenger

luckily there are alternatives:
https://blog.torproject.org/tor-heart-onion-messaging

.. and maybe someday

Note: See TracTickets for help on using tickets.