Opened 9 years ago

Closed 8 years ago

#1649 closed defect (fixed)

Segmentation fault while using HTTPS-Everywhere for Mozilla

Reported by: gk Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi,

I get a segmentation fault while surfing to http://mxr.mozilla.org/mozilla1.9.2/ and entering, for instance, "SSL" into the "Search For:" field there and pressing ENTER.

But this occurrs probably only if you have an extension installed that tries to modify the Accept-Header (via setrequestheader). (At least that was how I recognized the problem.)

It turned out that the problem is due to the fact that you forgot to put the code in the replaceURI-function in HTTPSRules.js in a try-catch clause. After having done that, everything worked fine again.

Steps to reproduce:

1) Put HTTPS-Everyhwere and an extension that modifies the accept-Header (e.g. the JonDoFox extension which you may found here: http://anonymous-proxy-servers.net/en/jondofox/download) in a new profile
2) Make sure the Mozilla checkbox in the HTTPS-Everywhere preference is checked and surf to http://mxr.mozilla.org/mozilla1.9.2/
3) There, type "SSL" (or whatever) into the Search For: field and hit ENTER.

Result: Segmentation fault

Reproducible: always, on Linux- as well as on Windows-systems

If you need further information or just want our extension (and not the whole browser profile with a bunch of extensions) for testing purposes, feel free to drop me an email to g.koppen@…

Child Tickets

Change History (5)

comment:1 Changed 9 years ago by bee

Yeah!!!! HTTPS-Everywhere is doing that even with my BeeFree addon!!!!!!!!!!!!!!!!

Just surfing on the net, to get crashes!!!!! It happens sometimes!! Well, this is my session on identi.ca, google and the NYT, all of which are supported by HTTPS Everywhere!! http://pastebin.com/KkfW8Ptw suddenly firefox froze!!!!!!! without doing anything at all, but surfing!!! though it's very very strange!!! BeeFree edits the Accept-* headers every time, always!!, but firefox crashes only sometimes!!!!! So, maybe, it's not even related with those http headers!!!
I also highlighted another minor error in "HTTPSRules.js"!! (lol!!! it's almost the only one line i didn't edited in my enhancement patch!! hahahah!!!!!!!!!!!!!)

~bee!!!!!

comment:2 Changed 9 years ago by bee

I think i found how to solve this!!!!!!!!!! and what is the flaw!!!!!!

This is the workaround solution: http://pastebin.com/YXV85U15 !!! It's mostly a fault of "uri.scheme ="!!!!!!!!!!!!!!!!
Sometimes you cannot change it!!!!!!! https://developer.mozilla.org/en/nsIURI

«The scheme is the protocol to which this URI refers. The scheme is restricted to the US-ASCII charset per RFC2396.

Warning: Setting this is highly discouraged outside of a protocol handler implementation, since doing so will generally lead to unpredictable results.»

Well, the unpredictable results are predictable crashes!!!!!!!!!!!!!!!!!
Also, the other values, like userPass, generate errors!!! So i just added one return, to quit at the first error!!!

I you log in, in debug mode, you'll find a lot of "Error at" errors (http://pastebin.com/UbUVv4QS) But, at least, firefox won't crash!!!!!!!!!!!!!!!!!!!
The errors raise usually at favicons loadings!!!

bee!!!!!!!!!
~bee!!!!!

comment:3 Changed 9 years ago by pde

Is this bug still reproducible in 0.3.0.development.1?

comment:4 in reply to:  3 Changed 9 years ago by gk

Replying to pde:

Is this bug still reproducible in 0.3.0.development.1?

Frankly, I do not know. But I have tested the 0.9.0 and am not able to reproduce the bug anymore. Thus, the bug can be closed.

comment:5 Changed 8 years ago by pde

Resolution: fixed
Status: newclosed

Ok, closing.

Note: See TracTickets for help on using tickets.