Opened 4 years ago

Closed 4 years ago

#16501 closed defect (duplicate)

7 hsdir calls

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: - Select a component Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have a small threaded program that connects to the tor socks port and issues a GET request on hidden services.

I noticed that if it makes 7 concurrent calls to one hidden service, then all of the requests will fail immediately.

If it makes 6 concurrent calls then it is successful, for anything more than 6, a pause or sleep between calls was needed.

I think it is calling all 6 hsdirs and not waiting for a reply from any of them, and with the 7th call it fails all 7 requests on the spot.

Relevant log lines:

X 7 times

[info] connection_ap_handshake_rewrite_and_attach(): Got a hidden service request for ID 'mmmmmmmmmmmmmmmm'
[info] connection_ap_handshake_rewrite_and_attach(): Unknown descriptor mmmmmmmmmmmmmmmm. Fetching.

X 3 times, each time to a different hsdir

[info] directory_get_from_hs_dir(): Sending fetch request for v2 descriptor for service 'mmmmmmmmmmmmmmmm' with descriptor ID 'iddddddddddddddddddd111111111111', auth type 0, and descriptor cookie '[none]' to hidden service directory $fffffffffffffffff11111111111111111111111~nickname at aaa.aaa.aaa.aaa

X 3 times, each time to a different hsdir

[info] directory_get_from_hs_dir(): Sending fetch request for v2 descriptor for service 'mmmmmmmmmmmmmmmm' with descriptor ID 'iddddddddddddddddddd222222222222', auth type 0, and descriptor cookie '[none]' to hidden service directory $xxxxxxxxxxxxxxxxx22222222222222222222222~nickname at bbb.bbb.bbb.bbb


[info] directory_get_from_hs_dir(): Could not pick one of the responsible hidden service directories, because we requested them all recently without success.
[info] rend_client_refetch_v2_renddesc(): Could not pick one of the responsible hidden service directories to fetch descriptors, because we already tried them all unsuccessfully.
[notice] Closing stream for 'mmmmmmmmmmmmmmmm.onion': hidden service is unavailable (try again later).
[info] rend_client_note_connection_attempt_ended(): Connection attempt for mmmmmmmmmmmmmmmm has ended; cleaning up temporary state.

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by teor

Resolution: duplicate
Status: newclosed

This is a duplicate of #15937.

Please check that task for updates.

Note: See TracTickets for help on using tickets.