Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#16522 closed defect (fixed)

Tor Browser 5.0a3 has Yahoo as default search engine

Reported by: arthuredelstein Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: ff38-esr, TorBrowserTeam201507R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A user noticed this regression. It looks like it may be related to a new interface in the search box.

Child Tickets

Change History (6)

comment:1 Changed 4 years ago by arthuredelstein

Keywords: ff38-esr added

comment:2 Changed 4 years ago by arthuredelstein

Keywords: TorBrowserTeam201507R added; removed
Status: newneeds_review

Here's a patch for review, sets Disconnect to the default search engine, and ensures that the name "Disconnect" is used in the search box drop down menu. I confirmed that Disconnect is the default in the Omnibox, search box, and when selected text is right-clicked.

https://github.com/arthuredelstein/tor-browser/commit/16522

comment:3 Changed 4 years ago by mikeperry

Marked #16509 as a duplicate of this.

comment:4 Changed 4 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

This looks fine to me. I tested and merged it for 5.0-next.

comment:5 in reply to:  4 Changed 4 years ago by gk

Replying to mikeperry:

This looks fine to me. I tested and merged it for 5.0-next.

Last time you argued against using "Disconnect" in the search boxes due to concerns users could get confused (maybe they think they are disconnecting from the Tor network). I am fine with that argumentation. Could you explain what changed your mind? The "Search Search for" instead "Search Disconnect for" issue? Or was this an oversight? Or...?

comment:6 Changed 4 years ago by mikeperry

The omnibox text in FF38 now says "Search" in it regardless of the selected engine. Hence, it seemed better to name the Disconnect search choice as "Disconnect", so that people can select it and not have it say "Your default engine is now 'Search'".

Note: See TracTickets for help on using tickets.