Opened 4 years ago

Closed 4 years ago

#16523 closed defect (fixed)

Browser/Chrome Javascript Debugger Broken in Tor Browser

Reported by: mikeperry Owned by: gk
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-5.0a4, TorBrowserTeam201507
Cc: gk, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Mozilla deprecated the Venkman debugger (https://addons.mozilla.org/en-us/firefox/addon/javascript-debugger/) in favor of the in-browser debugger (https://developer.mozilla.org/en-US/docs/Debugging_JavaScript#JavaScript_Debugger) for debugging addons and browser javascript.

Unfortunately, the instructions on that page do not work. I get a blank window that seems to just hang, without a connection attempt. I tried adding "127.0.0.1,localhost" to the network.proxy.no_proxies_on pref, on the assumption that the TCP connection was failing, but to no avail.

We should probably try to have this fixed soon, so that debugging addons and browser javascript is possible in TBB 5.0.

Child Tickets

Change History (9)

comment:1 Changed 4 years ago by gk

Cc: gk added

comment:2 Changed 4 years ago by mcs

Cc: mcs added

comment:3 Changed 4 years ago by gk

Owner: changed from tbb-team to gk
Status: newassigned

comment:4 Changed 4 years ago by mcs

Testing on Mac OS with a "standalone" tor-browser-38.1.0esr-5.0-1 build (tree updated today), I am able to reproduce what Mike saw. I can see that a second firefox process is started (which uses a 'chrome_debugger_profile' profile), but I just see a blank/empty window like Mike did.

I am not sure if this is helpful or not, but the command line for the 'debugger browser' is:

/Users/.../dev/tor/tor-browser/x/TorBrowser.app/Contents/MacOS/firefox -no-remote -foreground -profile /Users/.../dev/tor/tor-browser/x/TorBrowser.app/TorBrowser/Data/Browser/Caches/24f48hfn.default/chrome_debugger_profile -chrome chrome://browser/content/devtools/framework/toolbox-process-window.xul -purgecaches

comment:5 Changed 4 years ago by mikeperry

Keywords: tbb-5.0a4 added; tbb-5.0a removed

comment:6 Changed 4 years ago by gk

Keywords: ff38-esr removed
Summary: Browser/Chrome Javascript Debugger Broken in 5.0a3Browser/Chrome Javascript Debugger Broken in Tor Browser

Okay, this was fun to debug. First, this is no ESR 38 thing but visible since we switched to ESR 31. The problem is our DNS lookup patch preventing the lookup of localhost. (Note: you won't see this if you switch network.proxy.socks_remote_dns nor would it help to change network.proxy.no_proxies_on if that were the issue as a new profile is loaded by the debugger and all the changes you make in your Tor Browser apply to the default profile you use)

A decent fix seems to be hard-coding 127.0.0.1 for devtools.debugger.chrome-debugging-host in our default preferences. I'll attach a patch shortly.

comment:7 Changed 4 years ago by gk

Status: assignedneeds_review

comment:8 Changed 4 years ago by mcs

This looks like a good fix to me. r=mcs

comment:9 Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Merged as commit 620bf44ce7db28abb88cdddbf2e8004fe48726b8.

Note: See TracTickets for help on using tickets.