Opened 4 years ago

Closed 4 years ago

#16539 closed defect (fixed)

Still had 9 address policies cached at shutdown.

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: TorCoreTeam201508
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

moria1 running Tor 0.2.7.1-alpha-dev (git-130a9c0ac8aa13ac) exited (in a controlled way), and its last words were:

Jul 09 17:23:11.788 [notice] Clean shutdown finished. Exiting.
Jul 09 17:23:12.423 [warn] Still had 9 address policies cached at shutdown.
Jul 09 17:23:12.423 [warn]   1 [6]: reject 127.0.0.0/8:*
Jul 09 17:23:12.423 [warn]   2 [6]: reject 0.0.0.0/8:*
Jul 09 17:23:12.423 [warn]   3 [6]: reject 10.0.0.0/8:*
Jul 09 17:23:12.423 [warn]   4 [6]: reject 172.16.0.0/12:*
Jul 09 17:23:12.423 [warn]   5 [6]: reject 192.168.0.0/16:*
Jul 09 17:23:12.423 [warn]   6 [6]: reject 169.254.0.0/16:*
Jul 09 17:23:12.423 [warn]   7 [6]: accept *4:52519
Jul 09 17:23:12.423 [warn]   8 [6]: reject 198.50.156.78:*
Jul 09 17:23:12.423 [warn]   9 [40]: reject *4:*

I guess this is something somebody wants to know? :)

Child Tickets

Attachments (1)

cached-descriptors (2.3 KB) - added by nickm 4 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 4 years ago by arma

Jul 23 14:17:18.773 [warn] Still had 1 address policies cached at shutdown.
Jul 23 14:17:18.773 [warn]   1 [25]: reject *4:*

looks like it happens every time moria1 exits.

comment:2 Changed 4 years ago by arma

Aug 04 17:21:29.185 [warn] Still had 174 address policies cached at shutdown.
Aug 04 17:21:29.185 [warn]   1 [8]: reject 204.45.121.58:*
Aug 04 17:21:29.185 [warn]   2 [8]: reject 96.9.169.53:*
Aug 04 17:21:29.185 [warn]   3 [8]: reject 66.96.147.168:80
Aug 04 17:21:29.185 [warn]   4 [8]: reject 127.0.0.0/8:*
Aug 04 17:21:29.185 [warn]   5 [8]: reject 67.228.206.92:*
Aug 04 17:21:29.185 [warn]   6 [8]: reject 69.197.144.138:*
Aug 04 17:21:29.185 [warn]   7 [8]: reject 88.84.159.195:*
Aug 04 17:21:29.185 [warn]   8 [8]: reject 64.191.59.245:*
Aug 04 17:21:29.185 [warn]   9 [8]: reject 208.110.71.58:*
Aug 04 17:21:29.185 [warn]   10 [8]: reject 0.0.0.0/8:*

comment:3 Changed 4 years ago by arma

Check out #672 for when this happened before. Gosh.

comment:4 Changed 4 years ago by nickm

Weird, I just started seeing this too:

Aug 12 11:50:50.000 [warn]   1 [24]: accept *4:464
Aug 12 11:50:50.000 [warn]   2 [1]: reject 208.64.121.161:*
Aug 12 11:50:50.000 [warn]   3 [7]: reject 204.12.248.66:*
Aug 12 11:50:50.000 [warn]   4 [24]: accept *4:6697
Aug 12 11:50:50.000 [warn]   5 [7]: reject 204.45.119.90:*
Aug 12 11:50:50.000 [warn]   6 [27]: accept *4:995
Aug 12 11:50:50.000 [warn]   7 [2]: reject 188.138.17.15:*
Aug 12 11:50:50.000 [warn]   8 [24]: accept *4:981
Aug 12 11:50:50.000 [warn]   9 [24]: accept *4:3389
Aug 12 11:50:50.000 [warn]   10 [7]: reject 204.12.237.202:*

This seems to happen when I'm starting Tor with some old descriptors in the cache.

Changed 4 years ago by nickm

Attachment: cached-descriptors added

comment:5 Changed 4 years ago by nickm

I've attached a minimal cached-descriptors file that reproduces this issue for me.

comment:6 Changed 4 years ago by nickm

Keywords: TorCoreTeam201508 added
Status: newneeds_review

Found it! Fix available in bug16539; needs quick review.

comment:7 Changed 4 years ago by yawning

LGTM. I assume you know if this case should log or not, since the code itself is inconsistent about when to log vs return, and I don't want to look at all the callers.

comment:8 Changed 4 years ago by nickm

Thanks for the review; merged!

comment:9 Changed 4 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

Closing, since I merged yesterday.

Note: See TracTickets for help on using tickets.