Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1655 closed defect (duplicate)

Windows 2000 crashes with "The procedure entry point freeaddrinfo could not be located in the dynamic link library WS2_32.DLL."

Reported by: anon1 Owned by:
Priority: High Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.1.26
Severity: Keywords: Windows 2000 freeaddrinfo tbb windows
Cc: anon1 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello,

After installing vidalia-bundle-0.2.1.26-0.2.9.exe, upon launching it crashes, with "The procedure entry point freeaddrinfo could not be located in the dynamic link library WS2_32.DLL.". My operating system is windows 2000 sp4 rollup 1 and all hotfixes.

The solution seems to be from MSDN "The freeaddrinfo function was added to the Ws2_32.dll on Windows XP and later. To execute an application using this function on earlier versions of Windows (Windows 2000, Windows NT, and Windows Me/98/95), then you must include the Ws2tcpip.h file and also include the Wspiapi.h file. When the Wspiapi.h include file is added, the freeaddrinfo function is defined to the WspiapiFreeAddrInfo inline function in the Wspiapi.h file. At runtime, the WspiapiFreeAddrInfo function is implemented in such a way that if the Ws2_32.dll or the Wship6.dll (the file containing freeaddrinfo in the IPv6 Technology Preview for Windows 2000) does not include freeaddrinfo, then a version of freeaddrinfo is implemented inline based on code in the Wspiapi.h header file. This inline code will be used on older Windows platforms that do not natively support the freeaddrinfo function.", link http://msdn.microsoft.com/en-us/library/ms737931(VS.85).aspx .

Child Tickets

Change History (7)

comment:1 Changed 9 years ago by phobos

Resolution: wontfix
Status: newclosed

As you've found, we don't support Windows 2000 due to the incompatible dlls.

comment:2 in reply to:  1 Changed 9 years ago by anon1

Cc: anon1 added
Resolution: wontfix
Status: closedreopened

Replying to phobos:

As you've found, we don't support Windows 2000 due to the incompatible dlls.

Hello phobos,

They are not incompatible dlls, it is just that "...you must include the Ws2tcpip.h file and also include the Wspiapi.h...."

The previous version vidalia-bundle-0.2.1.25-0.2.7.exe worked perfectly well, as all previous versions of tor or vidalia bundle have. Thank you.

comment:3 Changed 9 years ago by phobos

Vidalia 0.2.9 doesn't support anything prior to Windows XP due to your issue.

comment:4 Changed 9 years ago by edmanm

This is a duplicate of Vidalia ticket 596. I suggest re-closing this ticket, since it's a Vidalia bug (actually a miniupnpc bug) and the Vidalia ticket has more information in it. If the person who reopened the ticket wants to continue discussion, he can do so in the other ticket.

comment:5 Changed 9 years ago by nickm

Resolution: duplicate
Status: reopenedclosed

Closing as duplicate.

comment:6 Changed 8 years ago by karsten

Keywords: tbb windows added
Milestone: Tor Browser Bundle for Windows

comment:7 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.