Opened 4 years ago

Closed 4 years ago

#16589 closed defect (wontfix)

Fix permanent link in printed PDF output

Reported by: karsten Owned by:
Priority: Low Milestone:
Component: Metrics/ExoneraTor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I print the result of an IPv6 search to a PDF document using the PDF exporter that comes with Mac OS X, that document lets me follow that link, but it gets the link wrong. In particular, it omits the timestamp parameter value.

Example:

When printing the following page to PDF,

https://exonerator.torproject.org/?ip=[2001%3A858%3A2%3A2%3Aaabb%3A0%3A563b%3A1526]&timestamp=2015-01-01

the PDF contains the following link:

https://exonerator.torproject.org/?ip=[2001%3A858%3A2%3A2%3Aaabb%3A0%3A563b%3A1526]&timestamp

For some reason, this works just fine with IPv4 addresses.

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by qbi

I can't reproduce this with TBB 5.5a and Debian GNU/Linux. Do you Ctrl+p and select print to PDF?

comment:2 Changed 4 years ago by karsten

Resolution: wontfix
Status: newclosed

While trying to reproduce this, I found that it depends on where the link is wrapped. Everything that fits into the first line makes it into the link, the rest is dropped. This very much feels like a bug in the PDF printer that we can't debug here. And if you can't even reproduce this, even better. Closing as wontfix. Thanks for looking!

Note: See TracTickets for help on using tickets.