Opened 4 years ago

Closed 4 years ago

#16639 closed defect (fixed)

Check for Updates menu item can cause update failure

Reported by: mikeperry Owned by: mcs
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: TorBrowserTeam201507R, tbb-5.0a4
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Our Torbutton menu shortcut to "Check for Updates" can cause updates to fail if you click on it after an incremental update has already been successfully downloaded and applied, but you did not restart the browser yet. For some reason, it tries to download the update again (the full update mar this time) and then it reports an integrity error.

Clicking on it one more time then restarts the whole update process from the incremental.

Child Tickets

Change History (7)

comment:1 Changed 4 years ago by mikeperry

Keywords: tbb-5.0a4 added

In my ideal world, we'd solve this for 5.0a4, so we can set the pref from #16632 and see how that experience works out in an alpha before 5.0.

comment:2 Changed 4 years ago by mcs

Keywords: TorBrowserTeam201507R added; TorBrowserTeam201507 removed
Status: newneeds_review

It seems that we need to check the update state and open the prompt in the correct mode. Here is a fix:
https://gitweb.torproject.org/user/brade/torbutton.git/log/?h=bug16639-01

Please review.

comment:3 Changed 4 years ago by mikeperry

This is an improvement in the event that the download has completed, but it still seems to have issues if you re-enter the "Check for updates" dialog multiple times while a download is in progress.

If this reentrancy is a deeper Firefox bug that can't be fixed with checking more bits of the state, I say we merge this and file a new ticket. Covering the case where a download has already finished is the most important bit, IMO, and this seems to do that much at least.

comment:4 in reply to:  3 Changed 4 years ago by mcs

Replying to mikeperry:

This is an improvement in the event that the download has completed, but it still seems to have issues if you re-enter the "Check for updates" dialog multiple times while a download is in progress.

Kathy and I are unable to reproduce whatever you experienced (we tried on a Mac OS system and on an Ubuntu system). When we choose "Check for Tor Browser Update…" while the download is in progress, the window opens and shows "Downloading Tor Browser" along with the download progress bar. It does seem to take a few seconds to set the progress bar to a non-zero point and the "time remaining" estimate is much too low, but it doesn't seem terrible.

What behavior are you seeing?

comment:5 Changed 4 years ago by mikeperry

If I repeatedly opened and clicked "Hide" on the "Check for Updates" window, the progress bar did not seem to make progress, and sometimes would also reset to 0 progress.

I was testing on 5.0a2 though, updating to 5.0a3.

comment:6 in reply to:  5 Changed 4 years ago by mcs

Replying to mikeperry:

If I repeatedly opened and clicked "Hide" on the "Check for Updates" window, the progress bar did not seem to make progress, and sometimes would also reset to 0 progress.

I was testing on 5.0a2 though, updating to 5.0a3.

We tried again to reproduce the problems you are seeing (with both TB 5.0a2 and 5.0a3 on a Linux64 system). But the download and progress bar always seem to pick up where they left off. Can you set app.update.log = true and see what is logged when problems occur?

We do sometimes see the download restart after we restart the browser (but sometimes it picks up where it left off). Maybe we should open another ticket for that... probably a Mozilla bug but it is possible that the Tor network makes it happen more often somehow.

comment:7 Changed 4 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

Ok. I am now away from the computer I was using to test (which was Linux64). Perhaps there was some other issue with it. I merged this, since the behavior is better. I'll file a new bug about the weird multi-hide behavior if I can reproduce reliably on 5.0a4.

Note: See TracTickets for help on using tickets.