Opened 4 years ago

Closed 3 weeks ago

#16724 closed defect (worksforme)

Tor Browser 5.0a4 crashes with fonts.conf file

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-crash, tbb-fingerprinting-fonts
Cc: arthuredelstein Actual Points:
Parent ID: #18097 Points:
Reviewer: Sponsor:

Description

Using dcf's fonts.conf file makes Tor Browser 5.0a4 crash. This does not happen with 5.0a3.

Child Tickets

Attachments (2)

fonts.conf (6.4 KB) - added by gk 4 years ago.
fontstacktrace (15.8 KB) - added by gk 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by gk

Attachment: fonts.conf added

comment:1 Changed 4 years ago by gk

Attached is a stacktrace I got. I have not looked closer at the problem but if you are removing the <rejectfont></rejectfont> parts 5.0a4 is not crashing with the fonts.conf file.

Seems to me more like an issue of "Do not use this fonts.conf file then!" than a real bug. But maybe I am wrong.

Changed 4 years ago by gk

Attachment: fontstacktrace added

comment:2 Changed 4 years ago by cypherpunks_backup

Keywords: tbb-crash added
Severity: Normal

comment:3 Changed 4 years ago by arthuredelstein

Parent ID: 18097

comment:4 Changed 4 years ago by arthuredelstein

Parent ID: 18097#18097

comment:5 Changed 3 weeks ago by Thorin

@gk... I think we can close this, yes?

comment:6 in reply to:  5 Changed 3 weeks ago by gk

Resolution: worksforme
Status: newclosed

Replying to Thorin:

@gk... I think we can close this, yes?

I can't reproduce it anymore, yes. So, this got fixed somehow. If someone wants to dig up when this stopped to be an issue, please do. For now this seems to work for me.

Note: See TracTickets for help on using tickets.