Opened 2 years ago

Closed 20 months ago

Last modified 20 months ago

#16725 closed defect (fixed)

TorBrowser fails maximizing while using diffrent homepage

Reported by: kleft Owned by: gk
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, GeorgKoppen201602, TorBrowserTeam201603R
Cc: kleft, brade, mcs, arthuredelstein, whonix-devel@…, gk, Blisset Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I installed the latest version 4.5.3 on my Windows 7 x64. As soon as I change the default homepage to anything else than "about:tor" the window-maximizing of TBB doesnt work. The Window jumps back to its original position and size while manual (drag and drop) maximizing works. Tested with search.disconnect.me and check.torproject.org.

Child Tickets

Attachments (1)

file.flv (1.1 MB) - added by kleft 2 years ago.
Error Video Capture

Download all attachments as: .zip

Change History (20)

Changed 2 years ago by kleft

Attachment: file.flv added

Error Video Capture

comment:1 Changed 2 years ago by kleft

Cc: kleft added

This issue also exists on TBB 5.0 / FF 38.2

comment:2 Changed 2 years ago by mcs

Cc: brade mcs added
Status: newneeds_information

I am not able to reproduce this problem. Have you changed any of the default settings within Tor Browser? Can you reproduce this problem if you download a new copy of Tor Browser 5.0 and install it into a new folder?

comment:3 Changed 2 years ago by proper

Status: needs_informationnew

When using a custom browser homepage, Tor Browser can no longer be maximized.

Tested with TBB 5.5a3 on Debian jessie.

Steps to reproduce:

  • start Tor Browser
  • set a custom browser homepage (using preferences or about:config browser.startup.homepage)
  • restart Tor Browser
  • click the window maximize button

Expected result:

Tor Browser maximization should just work like with the default about:tor homepage.

Actual result:

Tor Browser can no longer be maximized by pressing the maximization button.

comment:4 Changed 2 years ago by arthuredelstein

Cc: arthuredelstein added

comment:5 Changed 2 years ago by proper

Cc: whonix-devel@… added

comment:6 Changed 2 years ago by arthuredelstein

Cc: gk added

The line that causes the window to resize after the user attempts to maximize is here:
https://gitweb.torproject.org/torbutton.git/tree/src/chrome/content/torbutton.js?id=a6f8dcec3bc11bcfc9ded64943051e2408ee9190#n3598

This code only runs when the "extensions.torbutton.startup_resize_period" is set to true. That pref is set to false in the torbutton_on_abouttor_load function, which is triggered by the custom "AboutTorLoad" event, created by the about:tor page (aboutTor.xhtml).

So it seems the pref is only turned off when about:tor is loaded. We need to find the right place to turn off this pref regardless of whatever page is loaded in a new window. Maybe gk has a suggestion?

comment:7 Changed 2 years ago by kernelcorn

Severity: Normal

I can reproduce this bug in Tor Browser 5.0.4, Fedora 23, Cinnamon desktop.

arthuredelstein is correct, about:tor is the only homepage that allows the Tor Browser to maximize. Any other homepage, including the error page when the browser is unable to recover tabs, prevents it from maximizing.

The workaround is to open about:tor in a new tab and then close it again, thus restoring functionality.

Last edited 2 years ago by kernelcorn (previous) (diff)

comment:8 Changed 21 months ago by bugzilla

Keywords: tbb-usability added
Priority: Very LowMedium

#18174 is a duplicate

comment:9 Changed 21 months ago by cypherpunks

Still facing this issue in TBB 5.5 Nix machine.

Last edited 21 months ago by cypherpunks (previous) (diff)

comment:10 Changed 21 months ago by gk

Cc: Blisset added
Keywords: TorBrowserTeam201602 GeorgKoppen201602 added
Owner: changed from tbb-team to gk
Status: newassigned

Resolved #18303 as duplicate.

comment:11 Changed 20 months ago by gk

Keywords: TorBrowserTeam201602R added; TorBrowserTeam201602 removed
Status: assignedneeds_review

bug_16725 (https://gitweb.torproject.org/user/gk/torbutton.git/commit/?h=bug_16725&id=2366b462f8541f4804a8d2781864d7ef18e4938d) in my public torbutton repo has an idea for how to fix this issue.

comment:12 Changed 20 months ago by gk

Keywords: TorBrowserTeam201603R added; TorBrowserTeam201602R removed

comment:13 Changed 20 months ago by gk

arthuredelstein, mcs, brade: I'd like to include this fix into the next stable (which is due next Tuesday) if any of you could look at my change and test the result a bit that would rock.

comment:14 in reply to:  13 ; Changed 20 months ago by mcs

Replying to gk:

arthuredelstein, mcs, brade: I'd like to include this fix into the next stable (which is due next Tuesday) if any of you could look at my change and test the result a bit that would rock.

I looked at your changes and also tested them on Mac OS. The problem of not being able to resize seems to be fixed. I don't fully understand how all of the pieces of the Torbutton resizing code fit together, but I think your changes are OK. It would be good to do some testing on Windows and Linux; if no one else gets to it, Kathy and I will do that tomorrow.

comment:15 in reply to:  14 Changed 20 months ago by mcs

Replying to mcs:

It would be good to do some testing on Windows and Linux; if no one else gets to it, Kathy and I will do that tomorrow.

I ran out of time yesterday but finished some more testing this morning. I did not find any problems when using the proposed patch on an Ubuntu 14.04 LTS system or on a Windows 7 system.

But it would still be good to get arthuredelstein's input if he has time.

comment:16 Changed 20 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

It seems he has not. Thanks for the review. This is commit 896e3d6525db8e7c4dd95edf95a59c63a727a578 on master and commit 8efd31f48447b454de98708fa899ab7bc12f85ae on maint-1.9.4.

comment:17 in reply to:  16 ; Changed 20 months ago by arthuredelstein

Replying to gk:

It seems he has not. Thanks for the review. This is commit 896e3d6525db8e7c4dd95edf95a59c63a727a578 on master and commit 8efd31f48447b454de98708fa899ab7bc12f85ae on maint-1.9.4.

My apologies -- I somehow missed the earlier message from this ticket. I have tested it now on OS X as well and the problem does indeed appear to be fixed. It does make sense to me that after the final startup-period resizing, we should immediately set the "extensions.torbutton.startup_resize_period" pref to false. I have not yet tested on Linux and Windows but I will and report here if I find anything not working.

comment:18 in reply to:  17 Changed 20 months ago by gk

Replying to arthuredelstein:

Replying to gk:

It seems he has not. Thanks for the review. This is commit 896e3d6525db8e7c4dd95edf95a59c63a727a578 on master and commit 8efd31f48447b454de98708fa899ab7bc12f85ae on maint-1.9.4.

My apologies -- I somehow missed the earlier message from this ticket. I have tested it now on OS X as well and the problem does indeed appear to be fixed. It does make sense to me that after the final startup-period resizing, we should immediately set the "extensions.torbutton.startup_resize_period" pref to false. I have not yet tested on Linux and Windows but I will and report here if I find anything not working.

No worries. Indeed, I had the same idea and think that the mutation observer kicks in last (at least that was so in the past) which is why I reset the pref there after the resizing in it got handled.

comment:19 Changed 20 months ago by arthuredelstein

I have now tested Linux and Windows and they both look good to me.

Note: See TracTickets for help on using tickets.