Opened 4 years ago

Closed 4 years ago

#16768 closed defect (duplicate)

Incorrect change log URL in Software Update window

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version: Tor: unspecified
Severity: Keywords:
Cc: brade, mcs Actual Points:
Parent ID: #13512 Points:
Reviewer: Sponsor:

Description

When Tor browser displays an update alert, the Software Update window shows a web link which says: "View more information ABOUT this update." But the link does not point to information ABOUT the update, it points to the DOWNLOAD page. The Software Update window should display two links:

  1. Visit download page
  2. View change log

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by mcs

Cc: brade mcs added
Parent ID: #13512

We are working on making it so the link points to info. about the update; see #13512. We probably will not show two links in the update alert window because:

  1. We want to use Mozilla's updater implementation with as few modifications as possible.
  2. The "View more information about this update" will also include a download link, e.g., like https://blog.torproject.org/blog/tor-browser-501-released and similar blogs posts do.

comment:2 Changed 4 years ago by gk

Resolution: fixed
Status: newclosed

Marking this as duplicate of #13512 where the work got done.

comment:3 Changed 4 years ago by gk

Resolution: fixed
Status: closedreopened

comment:4 Changed 4 years ago by gk

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.