Opened 9 years ago

Closed 9 years ago

#1684 closed defect (fixed)

HTTPS Everywhere: Aborting possible favicon [IMAGE], should be HTTPS!

Reported by: pde Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Certain correctly-written rulesets cause this error message to appear frequently in the Error Console. We believe the bug may simultaneously randomly prevent the image from rendering.

The bug is caused by a race condition between the favicon abort code we borrowed from NoScript, and the nsIContentPolicy codepath. The favicon abort code unfortunately appears to be necessary in order to prevent frequent crashes from an underlying Firefox bug.

There may be some workaround we can implement by tightening the favicon heuristics in replaceChannel(). But until that has been demonstrated and tested, we will have to avoid shipping rules that trigger the error frequently. You can keep using them privately, but they will occasionally prevent some image from rendering.

Child Tickets

Change History (1)

comment:1 Changed 9 years ago by pde

Resolution: fixed
Status: newclosed

Should be fixed 0.3.0.development.1

Note: See TracTickets for help on using tickets.