Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#16847 closed defect (worksforme)

torbrowser-install-5.0_en-US.exe does not start on Vista 32-bit

Reported by: ljacob Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

cannot start setup program.   have tried running as Administrator (no success).  when 'torbrowser-install-5.0_en-US.exe' is double-clicked on, nothing happens.  no errors are found in Event Viewer.

have also tried 'torbrowser-install-4.5.3_en-US.exe' and 'torbrowser-install-5.5a1_en-US.exe' they also do not run.

Child Tickets

Change History (9)

comment:1 Changed 4 years ago by ljacob

Just tested 'torbrowser-install-5.0.1_en-US.exe', no change. Setup does not start.

comment:2 Changed 4 years ago by mcs

Cc: brade mcs added
Status: newneeds_information

I successfully installed (and used) torbrowser-install-5.0.1_en-US.exe on a 32-bit Vista system. Is is possible that your anti-virus or other anti-malware software is blocking the installation?

comment:3 Changed 4 years ago by ljacob

Not running antivirus, or antimalware software. System is fresh (just formatted, all drivers and Windows updates installed). Also, I'm not the only one with this issue (torforum viewtopic.php?f=2&t=65725). I'm using Vista Business edition (what are you using?) I did download and install 3.6.4 without any problems. Has the installer torbrowser uses changed in any way (version, default settings etc) since 3.6.4?

comment:4 Changed 4 years ago by cypherpunks

Also, I'm not the only one with this issue (torforum viewtopic.php?f=2&t=65725)

Link is about torforum.org/viewtopic.php?f=2&t=65725

Has the installer torbrowser uses changed in any way (version, default settings etc) since 3.6.4?

Difference inbetween NSIS script for Tor Browser Bundle Windows installer v0.1 (used by 3.6.4) and v0.3 (used by 4.5 and 5.0):

--- torbrowser.nsi.v0.1	2013-06-14 21:50:20.000000000 +0000
+++ torbrowser.nsi.v0.3	2015-03-18 04:56:58.000000000 +0000
@@ -13,7 +13,7 @@
   ; location of Tor Browser bundle to put into installer
   !define TBBSOURCE ".\Tor Browser\"  
 
-  Name "Tor Browser Bundle"
+  Name "Tor Browser"
   OutFile "torbrowser-install.exe"
 
   ;Default installation folder
@@ -35,7 +35,11 @@
 ;--------------------------------
 ;Modern UI settings
   !define MUI_FINISHPAGE_NOREBOOTSUPPORT     ; we don't require a reboot
-  !define MUI_FINISHPAGE_RUN                 "$INSTDIR\Start Tor Browser.exe"
+  !define MUI_FINISHPAGE_RUN
+  !define MUI_FINISHPAGE_RUN_FUNCTION "StartTorBrowser"
+  !define MUI_FINISHPAGE_SHOWREADME ; misuse for option to create shortcut; less ugly than MUI_PAGE_COMPONENTS
+  !define MUI_FINISHPAGE_SHOWREADME_TEXT "&Add Start Menu && Desktop shortcuts"
+  !define MUI_FINISHPAGE_SHOWREADME_FUNCTION "CreateShortCuts"
 ;--------------------------------
 ;Pages
 
@@ -125,9 +129,17 @@
 
   SetOutPath "$INSTDIR"
   File /r "${TBBSOURCE}\*.*"
-  
+  SetOutPath "$INSTDIR\Browser"
+  CreateShortCut "$INSTDIR\Start Tor Browser.lnk" "$INSTDIR\Browser\firefox.exe"
+
 SectionEnd
 
+Function CreateShortcuts
+
+  CreateShortCut "$SMPROGRAMS\Start Tor Browser.lnk" "$INSTDIR\Browser\firefox.exe" 
+  CreateShortCut "$DESKTOP\Start Tor Browser.lnk" "$INSTDIR\Browser\firefox.exe"
+
+FunctionEnd
 ;--------------------------------
 ;Installer Functions
 
@@ -147,5 +159,9 @@
  NoAbort:
 ${EndIf}
 FunctionEnd
- 
+
+
+Function StartTorBrowser
+ExecShell "open" "$INSTDIR/Start Tor Browser.lnk"
+FunctionEnd

comment:5 Changed 4 years ago by cypherpunks

Internet "says" it's probably about blocking executable files downloaded from internet. Two workarounds:

  1. Right-click > Properties > Unblock. or. General --> Security, click "Unblock" and then "Apply"
  2. Copy it to non-NTFS drive before install.
Last edited 4 years ago by cypherpunks (previous) (diff)

comment:6 Changed 4 years ago by ljacob

Success!  "unblocking" the application works! (also copied to FAT32 usb key, that worked too).

Also noticed 5.0.1 installer (vs 3.6.4) adds "Digital Signature" tab in Properties, was this part of the problem?

Unsure why Vista didn't prompt me to unblock in the first place?

Thanks everyone!

comment:7 Changed 4 years ago by gk

Resolution: worksforme
Status: needs_informationclosed

Glad that it worked. I don't hope signing the binaries is the problem here as it is actually intended to avoid scary warnings and make the installation process smoother...

comment:8 Changed 4 years ago by cypherpunks

was this part of the problem?

Depends tools used to download 3.6.4 vs 5.0.1, if they both has been downloaded using then same browser (downloader) to the same folder then yes some signatures is a problem for your Vista Business. Siganture could be problem if Vista has no valid certs to check it, then probably it programmed to count such case files as more suspicious than exes without signatures?

comment:9 Changed 4 years ago by cypherpunks

Another report. Certs expired, nuked? Somebody with fresh Vista need for more investigation.

Note: See TracTickets for help on using tickets.