Opened 5 years ago

Closed 5 years ago

#16855 closed defect (fixed)

TorBrowser 5.0.1 fails to download any file from https://mega.nz. TorBrowser 4.5.3 works,

Reported by: bbb Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-5.0-regression, tbb-usability-website, TorBrowserTeam201510R
Cc: brade, mcs, arthuredelstein Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

  • Try to download any file stored on https://mega.nz with TorBrowser 5.0.1.
  • Result: At the end of the download process, you are not prompted to choose where to save the file on your hard disk.

Note that TorBrowser 4.5.3 has not the issue.

Tested with TorBrowser 5.0.1 on OS X 10.10.5.

Child Tickets

Change History (23)

comment:1 Changed 5 years ago by gk

Keywords: tbb-5.0-regression tbb-usability-website added; mega download fails removed
Priority: blockernormal
Version: Tor: unspecified

Hm... how do I get https://mega.nz loaded at all in the first place? I always get a blank page. That said I see there is no prompt in 5.0.1 at the end of the download. Thus, this is probably indeed a regression (although I could not test it).

comment:2 Changed 5 years ago by mcs

Cc: brade mcs added

comment:3 Changed 5 years ago by torbacchi

how do I get ​https://mega.nz loaded at all in the first place

Good question. mega.nz (and mega.co.nz) used to work perfectly with tbb 4.5.3 until a few days ago.
Now I get a blank page even with 4.5.3, so maybe this is not (only) a 5.0.1 issue and something changed on mega.nz side too :(

comment:4 Changed 5 years ago by cypherpunks

The blank page is a new error that affects other browsers as well.
https://forum.palemoon.org/viewtopic.php?t=9147&p=61771

The original problem is that document.createElement('a').origin is "" and therefore when mega inserts a blob link it has the wrong origin for the new blob restrictions in 5.0. I'm having the same problem with a greasemonkey script inserts a blob link. Clicking the link does not download the file in the blob like it did in 4.5.3.

Last edited 5 years ago by cypherpunks (previous) (diff)

comment:5 Changed 5 years ago by torbacchi

BTW plain Firefox 38.2.0 (not the modified version of the TBB) works just fine; I guess it has some workarounds for the buggy mega.nz javascript code that TBB 5.0 lacks

comment:6 Changed 5 years ago by arthuredelstein

Cc: arthuredelstein added

comment:7 Changed 5 years ago by arthuredelstein

I tracked down this problem to what appears to be a bug in vanilla Firefox:
https://bugzilla.mozilla.org/show_bug.cgi?id=1198559

comment:8 Changed 5 years ago by gk

Keywords: TorBrowserTeam201508 added

Testing the (fixed) WIP patch helps in resolving this issue. We can think of backporting it in case there is no official patch that lands meanwhile.

comment:9 Changed 5 years ago by torras

+1 for backporting this patch. This issue makes TBB completely useless when attempting to share files. Thanks!

comment:10 Changed 5 years ago by torbacchi

Is there a way to fix this bug on a live TBB instance, by applying the patch mentioned above, or editing any files?

comment:11 Changed 5 years ago by mikeperry

Keywords: TorBrowserTeam201509 added; TorBrowserTeam201508 removed

Move remaining August tickets to September.

comment:12 Changed 5 years ago by torbacchi

I upgraded to 5.0.2 (on Linux) and mega is now back working as usual (though I'm not sure if the upgrade did the trick and/or folks at mega have fixed something on their side too).

comment:13 Changed 5 years ago by qwas

Is not fixed for me using TBB 5.0.2 on OS X 10.10.5. Just tested.

comment:14 in reply to:  13 Changed 5 years ago by torbacchi

Replying to qwas:

Is not fixed for me using TBB 5.0.2 on OS X 10.10.5. Just tested.

Ouch, you're right. 5.0.2 allows me to access mega and log into my mega account, but when I try to download a file, I get the same problem described by the OP (progress bar hits 100% then nothing happens).

comment:15 Changed 5 years ago by mikeperry

Keywords: TorBrowserTeam201509R added; TorBrowserTeam201509 removed
Status: newneeds_review

Yes, we should review the WIP patch and just grab it. I don't think there will be motion on this on Mozilla's end.

comment:16 Changed 5 years ago by arthuredelstein

Here's a page with a test file:
https://mega.nz/#!wQJgTArS!1glDk1JJo0Z52bwPOG8kkUdkyKxHBQKpT-ni9fzZX2w

Click on the "Download through your browser" link.

Last edited 5 years ago by arthuredelstein (previous) (diff)

comment:17 Changed 5 years ago by arthuredelstein

comment:18 Changed 5 years ago by arthuredelstein

I proposed a possible patch to Boris Zbarsky:
https://bugzilla.mozilla.org/show_bug.cgi?id=1198559#c14

comment:19 Changed 5 years ago by arthuredelstein

Here's a patch (for review) that makes a minimal change to make blobs downloadable:
https://github.com/arthuredelstein/tor-browser/commit/16855

Tanvi at Mozilla is working on more extensive revisions:
https://bugzilla.mozilla.org/show_bug.cgi?id=1198559#c15
After Tanvi's patches land, we may be able to get rid of this patch.

comment:20 Changed 5 years ago by mikeperry

I merged this for 5.5a3, but since the check is really only altering the <a download=""> case, I am tempted to push it for 5.0.3 as well.

comment:21 Changed 5 years ago by gk

Moving needs_review tickets to October 2015.

comment:22 Changed 5 years ago by gk

Keywords: TorBrowserTeam201510R added; TorBrowserTeam201509R removed

Batch modification for realz now.

comment:23 Changed 5 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

This is already on the 5.0 branch as well (f073809a9306f9ae6acf29b42ef7afaedee0c18b). Thus, closing.

Note: See TracTickets for help on using tickets.