Opened 4 years ago

Closed 4 years ago

#16872 closed defect (fixed)

Opening about:downloads creates a bunch of Private Browsing Mode related warnings

Reported by: gk Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-5.0-regression, TorBrowserTeam201508
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Opening about:downloads in Tor Browser 5 I get

WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
getData@resource:///modules/DownloadsCommon.jsm:242:9
DownloadsPlacesView@chrome://browser/content/downloads/allDownloadsViewOverlay.js:533:25
init@chrome://browser/content/downloads/contentAreaDownloadsView.js:9:16
onload@about:downloads:1:1
WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
getIndicatorData@resource:///modules/DownloadsCommon.jsm:264:9
DownloadsPlacesView@chrome://browser/content/downloads/allDownloadsViewOverlay.js:538:3
init@chrome://browser/content/downloads/contentAreaDownloadsView.js:9:16
onload@about:downloads:1:1
WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
init@chrome://browser/content/downloads/contentAreaDownloadsView.js:11:10
onload@about:downloads:1:1

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by gk

This is actually a Mozilla bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1192120. It got fixed in a recent nightly.

comment:2 Changed 4 years ago by gk

Keywords: TorBrowserTeam201508 added
Resolution: fixed
Status: newclosed

Okay, I applied Ehsan's patch to the 5.0 (commit 1efbcfcb50459140bf7c606a85d07e73600db414) and 5.5 branch (commit 470b0fd685c904874254413aebdfb2de84927c47). And as there were no conflicts I decided there is no need to review that (the patch already got review in Mozilla's context).

comment:3 Changed 4 years ago by mikeperry

Resolution: fixed
Status: closedreopened

We dropped this from 5.5a2 and 5.0.1 due to the urgency of the release. Reopening so we remember to re-merge this after Thursday's release.

comment:4 Changed 4 years ago by gk

Resolution: fixed
Status: reopenedclosed

This is commit 641feb2e095bfb8bdcea91851c7be9e0c1329a26 (tor-browser-38.2.1esr-5.5-2) and commit 0febd3270179aa6e9ec7255181612764d074f5f6 (tor-browser-38.2.1esr-5.0-2) now.

Note: See TracTickets for help on using tickets.