Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#16910 closed defect (fixed)

Tor Browser app bundle has wrong copyright year (Mac OS)

Reported by: mcs Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-gitian, TorBrowserTeam201509R
Cc: gk, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When doing some quick "sanity check" testing of the TB 5.0.2 candidate builds, I noticed that "Get Info" on Mac OS still shows 2014 as the copyright year. This is because the year is hardcoded inside gitian/build-helpers/fix-info-plist.py within the tor-browser-bundle repo.

Should we just change the YEAR value to "2015" in that file or should we use a command like date '+%Y' to automatically use the current year? I guess a similar problem does not exist on Windows because no year is included in the firefox.exe copyright (see browser/app/module.ver within the tor-browser repo).

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by gk

Keywords: tbb-gitian added

Dealing with this issue once and for all sounds like a good idea.

comment:2 Changed 4 years ago by mcs

Keywords: TorBrowserTeam201509R added
Status: newneeds_review

Here is a proposed fix:
https://gitweb.torproject.org/user/brade/tor-browser-bundle.git/commit/?h=bug16910-01&id=90aa526e3d4de29660e69ad3839a0439d7dc22cc
To ensure reproducibility even if someone builds during a different calendar year, this patch grabs the year from the date of the last tor-browser commit and inserts that as the copyright year on Mac OS.
Please review.

Also, this is not a problem on Windows because the firefox.exe resource does not include a year in the copyright field. Maybe we should add "Tor Project" to the copyright notices on Windows? I wonder if there is already a ticket for that issue.

comment:3 in reply to:  2 ; Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Replying to mcs:

Here is a proposed fix:
https://gitweb.torproject.org/user/brade/tor-browser-bundle.git/commit/?h=bug16910-01&id=90aa526e3d4de29660e69ad3839a0439d7dc22cc
To ensure reproducibility even if someone builds during a different calendar year, this patch grabs the year from the date of the last tor-browser commit and inserts that as the copyright year on Mac OS.
Please review.

Looks good. Applied to master (commit 5019358bcac86508260703ae9cd99a4dfd2983e1) and maint-5.0 (commit 7d0d8bb670f93be292997d6483825f661a29583f).

Also, this is not a problem on Windows because the firefox.exe resource does not include a year in the copyright field. Maybe we should add "Tor Project" to the copyright notices on Windows? I wonder if there is already a ticket for that issue.

I don't think so. Care to file one?

comment:4 in reply to:  3 Changed 4 years ago by mcs

Replying to gk:

Also, this is not a problem on Windows because the firefox.exe resource does not include a year in the copyright field. Maybe we should add "Tor Project" to the copyright notices on Windows? I wonder if there is already a ticket for that issue.

I don't think so. Care to file one?

Done. See #17063.

Note: See TracTickets for help on using tickets.