Opened 5 years ago

Closed 5 years ago

#16922 closed defect (not a bug)

Persistent relay in tor circuit

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version: Tor: unspecified
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi there,

Running tor 5.0.2 on OSX. I have searched around quite a bit but am coming up shorts. Every time I generate a new tor circuit or restart tor entirely, the first node is the same server 184.100.166.110 https://atlas.torproject.org/#search/184.100.166.110 and I'm not sure why or how.

My first thought it was me updating torrc to allow for IRC, but after removing those rules and restarting, the relay still appeared. Second was that maybe my ISP automatically routes all tor users through a specific set of servers somewhere, so I tried to connect over different VPNs, and the relay still persisted.

I can't find any information for blacklisting relays, everything instead points to blocking tor entirely.

tor check says it's configured properly, showing the last IP of the circuit, no DNS leaks, but I'm not entirely comfortable with all of my anonymous traffic passing through the same server over and over again.

any solutions?

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by special

Resolution: not a bug
Status: newclosed

This is an intentional and important defense. By using the same relay as your entry point long term (2-3 months), you reduce the chances of using an entry point that wants to attack you. These are called 'guard relays'. See also this FAQ entry:

https://www.torproject.org/docs/faq.html.en#EntryGuards

Also please note that this bug tracker is for bugs, not for support. There are some great resources for getting support at https://www.torproject.org/about/contact.html.en

Note: See TracTickets for help on using tickets.