Opened 3 years ago

Closed 3 years ago

#16930 closed defect (not a bug)

The default facilitator seems to provide only a few servers.

Reported by: Arthur2e5 Owned by: dcf
Priority: Medium Milestone:
Component: Archived/Flashproxy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have been running the server for a while in a debug&unsafe way, and finally I got a server saying relay:{ host: "192.81.135.242", port: 9901 }.

To satisfy my curiousity, I search for that IP address, and got one result in the example config, with one item perfectly matching it. So it appears that either I am so lucky that I hit the example server, or the list is actually really that short.

The attachment is a naive bash script that parses network-status-microdesc-consensus-3 (avaliable at https://collector.torproject.org/recent/relay-descriptors/microdescs/consensus-microdesc/) and generates a list.

Child Tickets

Attachments (4)

tor.awk (116 bytes) - added by Arthur2e5 3 years ago.
Sorry, but AWK is faster and simpler for this..
2015-08-31-03-00-00-consensus-microdesc.out (174.0 KB) - added by Arthur2e5 3 years ago.
Output for https://collector.torproject.org/recent/relay-descriptors/microdescs/consensus-microdesc/2015-08-31-03-00-00-consensus-microdesc
tor.2.awk (116 bytes) - added by Arthur2e5 3 years ago.
Sorry, but AWK is faster and simpler for this..
2015-08-31-03-00-00-consensus-microdesc.2.out (174.0 KB) - added by Arthur2e5 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by Arthur2e5

Attachment: tor.awk added

Sorry, but AWK is faster and simpler for this..

Changed 3 years ago by Arthur2e5

Attachment: tor.2.awk added

Sorry, but AWK is faster and simpler for this..

Changed 3 years ago by Arthur2e5

comment:1 Changed 3 years ago by dcf

Resolution: not a bug
Status: newclosed

Thank you for this report. It's not a bug. There is supposed to be just one actual relay behind the multiple flash proxies. (In fact it has to be that way, because Tor clients using flash proxy are expecting a relay with a certain fingerprint.)

The censorship resistance of flash proxy does not come from having a lot of websocket relays. It comes from having a lot of flash proxies (the JavaScript hop before the relay). That is what you are being when you run the flashproxy page.

I don't know who runs all the other websocket relays. Some of them have similar nicknames, so they may be all related.

Note: See TracTickets for help on using tickets.