Opened 3 years ago

Closed 3 years ago

#16958 closed defect (not a bug)

facilitator query URL keeps growing longer with duplicates

Reported by: Arthur2e5 Owned by: dcf
Priority: Medium Milestone:
Component: Archived/Flashproxy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I start flashproxy with debug, I got some ever-growing facilitator URLs, like:

Facilitator: connecting to https://fp-facilitator.org/?r=1&transport=websocket&client=[CLIENT_A]%3A9000&client=[CLIENT_A]%3A9000&client=[CLIENT_B]%3A9000&client=[CLIENT_B]%3A9000&client=[CLIENT_C]%3A9000&client=[CLIENT_C]%3A9000&client=[CLIENT_D]%3A9000&client=[CLIENT_D]%3A9000&client=[CLIENT_E]%3A9000&client=[CLIENT_E]%3A9000&client=[CLIENT_F]%3A9000&client=[CLIENT_F]%3A9000.

I think at least some dedup should be completed, AND maybe discarding some really old clients in the querys.

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by dcf

Resolution: not a bug
Status: newclosed

This is expected. You get two copies of each client because of this:

/* Start two connections because some versions of Tor make two PT connections:
https://lists.torproject.org/pipermail/tor-dev/2012-December/004221.html
https://trac.torproject.org/projects/tor/ticket/7733 */
var CONNECTIONS_PER_CLIENT = 2

As long as the client appears in the facilitator query URL, it means you are still actively providing service to that client. They're not really "old." When the client disconnects, it will disappear from the URL. There's a limit of 10 clients; once the proxy reaches that limit, it will stop polling until one of the client disconnects. So the URL will not grow forever.

Thanks for experimenting with flash proxy.

Note: See TracTickets for help on using tickets.