Opened 4 years ago

Closed 4 years ago

#16960 closed defect (fixed)

OSX `nightly` build target is broken.

Reported by: yawning Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-gitian, TorBrowserTeam201509R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Probably related to the #16901 changes, but I didn't think to save the build.log before going "fuck it, I know how to get the alpha target to build", sorry. 99% sure it was a configure time failure and not compile time though I may be wrong.

Since I have an alpha build going that I fully expect to succeed, I probably won't look into this further.

Child Tickets

Attachments (1)

openssl_check_error (3.7 KB) - added by gk 4 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 4 years ago by gk

Component: Tor BrowserTor
Keywords: tbb-gitian tbb-wants added; OSX openssl gitian removed
Milestone: Tor: 0.2.7.x-final

You are right. Cross-compiling tor in our Gitian setup is still broken as of commit eb71777bb28b353da68c0ea25a36d0ac763de550. The error is:

checking for openssl directory... /home/ubuntu/install/openssl
configure: error: OpenSSL is too old. We require 1.0.0 or later. You can specify a path to a newer one with --with-openssl-dir.

We are using OpenSSL 1.0.1p

comment:2 Changed 4 years ago by gk

Owner: changed from tbb-team to nickm
Status: newassigned

comment:3 Changed 4 years ago by yawning

Keywords: Post027Freeze TorCoreTeam201509 added
Priority: normalmajor

Tor Browser's OSX build cross-compiles tor using:

INSTDIR="$HOME/install"

 [snip]

export CFLAGS="-m64 -I/usr/lib/apple/SDKs/MacOSX10.6.sdk/usr/include/ -I/usr/lib/gcc/i686-apple-darwin10/4.2.1/include/ -I.  -L/usr/lib/apple/SDKs/MacOSX10.6.sdk/usr/lib/ -L/usr/lib/apple/SDKs/MacOSX10.6.sdk/usr/lib/system/ -mmacosx-version-min=10.5"
export LDFLAGS="-m64 -L/usr/lib/apple/SDKs/MacOSX10.6.sdk/usr/lib/ -L/usr/lib/apple/SDKs/MacOSX10.6.sdk/usr/lib/system/ -mmacosx-version-min=10.5"

 [snip]

./configure --enable-static-openssl --disable-asciidoc --host=i686-apple-darwin11 --with-libevent-dir=$INSTDIR/libevent --with-openssl-dir=$INSTDIR/openssl --prefix=$INSTDIR

https://gitweb.torproject.org/builders/tor-browser-bundle.git/tree/gitian/descriptors/mac/gitian-tor.yml

comment:4 Changed 4 years ago by nickm

Keywords: regression added

Hmmm. So, this was apparently caused by b79e90f6ba9426158cf305655590f70d3ae89875, which was meant to fix #16901.

Can we have a look at the relevant part of config.log ? (Just compress the whole thing and stick it somewhere if it's not clear which part is relevant.)

comment:5 Changed 4 years ago by gk

See the attached log parts. Let me know if you need more/different info.

Changed 4 years ago by gk

Attachment: openssl_check_error added

comment:6 Changed 4 years ago by nickm

Does putting "-I${INSTDIR}/openssl/include" early (at the start) of the CFLAGS line help?

comment:7 in reply to:  6 Changed 4 years ago by gk

Component: TorTor Browser
Keywords: TorBrowserTeam201509R added; tbb-wants Post027Freeze TorCoreTeam201509 regression removed
Milestone: Tor: 0.2.7.x-final
Status: assignedneeds_review

Replying to nickm:

Does putting "-I${INSTDIR}/openssl/include" early (at the start) of the CFLAGS line help?

Yes, it does. bug_16960 (https://gitweb.torproject.org/user/gk/tor-browser-bundle.git/commit/?h=bug_16960&id=96b9929f24d0461ec05b010c6a8d74506c8e2657) in my public tor-browser-bundle repo has the fix for review.

comment:8 Changed 4 years ago by gk

Owner: changed from nickm to tbb-team
Status: needs_reviewassigned

comment:9 Changed 4 years ago by nickm

Great; glad that worked! Let me know if something turns out wrong with it.

comment:10 Changed 4 years ago by gk

Status: assignedneeds_review

comment:11 Changed 4 years ago by mcs

This looks simple enough.
r=mcs

comment:12 Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks. This is commit 96b9929f24d0461ec05b010c6a8d74506c8e2657 on master.

Note: See TracTickets for help on using tickets.