Opened 4 years ago

Closed 3 years ago

#16977 closed defect (invalid)

Resizing Tor Browser window ruins default screen size, leaking it

Reported by: cypherpunks Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The automated resize of Tor Browser window when using a tiling window manager loses the preset default screen size. Not specifying a Tor Browser version because this is a problem for current, 5.0.2 Tor Browser version, but goes back to many older versions.

Problem can be seen on Linux with dwm-6.0 window manager.

Steps to reproduce:

  1. Set dwm to tiled mode. Default hotkey for this is Alt-t. dwm is in tiled mode by default.
  1. Make sure there are no other open windows on screen.
  1. Start Tor Browser. Its window will take all available screen space (since there are no other windows, see 2.) By default it will set screen size to 1000x600, as reported by https://panopticlick.eff.org
  1. Open some other window.
  1. Window of Tor Browser gets automatically resized, so the new window can fit in.
  1. Make sure the Tor Browser window is active (has focus).
  1. Switch the dwm layout to monocle (full screen, so active window takes all available space and covers up all other windows). Default hotkey for this is Alt-m.
  1. Notice the Tor Browser window expanding back to full screen, yet screen size expanding as well and eating up all available space inside the browser window. After this step, https://panopticlick.eff.org reports a modified, bigger screen size.

Child Tickets

Change History (3)

comment:1 Changed 3 years ago by bugzilla

Resolution: not a bug
Severity: Normal
Status: newclosed

Surely "automated resize" resizes window as any other resize! It is your responsibility.
And Tor Browser is constantly leaking its real resolution, not when changed.

Last edited 3 years ago by bugzilla (previous) (diff)

comment:2 Changed 3 years ago by bugzilla

Keywords: screen size removed
Resolution: not a bug
Status: closedreopened

comment:3 Changed 3 years ago by bugzilla

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.