Opened 3 years ago

Last modified 17 months ago

#16981 assigned defect

NoScript Option

Reported by: cypherpunks Owned by: ma1
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: noscript, tbb-usability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

NoScript's "Temporary allow all this page" allows ALL scripts for that particular website not just that page to execute javascript.

Is this the intended mechanic of how this option should work?

If so it is confusing as it only says it would allow javascript for that one particular page. How would it be possible to make sure javascript is enabled only for one page and not the entire website?

Child Tickets

Change History (4)

comment:1 Changed 3 years ago by gk

Resolution: not a bug
Status: newclosed

Yes, if you are choosing that option then the whole page (including resources it needs) are allowed which is why there is an *all* in it and not just "Temporarily allow this page".

Last edited 3 years ago by gk (previous) (diff)

comment:2 Changed 3 years ago by cypherpunks

Resolution: not a bug
Status: closedreopened

It allows much more than the page, it allows the entire primary domain/site. E.g. allowing scripts on a specific page on https://blog.torproject.org/some_page allows scripts on *.torproject.org/*.

The menu entry should be called something like "Temporarily allow this domain" or "Temporarily allow this site" or specifically stating the domain "Temporarily allow all torproject.org".

comment:3 in reply to:  2 Changed 3 years ago by gk

Replying to cypherpunks:

The menu entry should be called something like "Temporarily allow this domain" or "Temporarily allow this site" or specifically stating the domain "Temporarily allow all torproject.org".

I like the last idea. We only need someone filing a bug against NoScript now and getting that fixed in NoScript, too.

comment:4 Changed 17 months ago by cypherpunks

Keywords: noscript tbb-usability added
Owner: changed from tbb-team to ma1
Severity: Normal
Status: reopenedassigned
Note: See TracTickets for help on using tickets.