Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#17005 closed enhancement (invalid)

allow relays and bridges to set passwords

Reported by: elypter Owned by:
Priority: High Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: bridge password authentification
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

thats especially important for bridges. even when the new bridgedb distributor is completed and makes it impossible to collect many bridges there is a much more brute way of finding bridges:
if bridges reveal their nature to any client without authentification they become an easy target for mass ip scanning. with enough bandwith the whole internet can be scanned within minutes.
https://github.com/robertdavidgraham/masscan

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by yawning

Resolution: invalid
Status: newclosed

Pluggable transports fix this issue, apart from the fact that an OR port exists (#7349).

comment:2 Changed 5 years ago by isis

Possible duplicate of #7349.

Note: See TracTickets for help on using tickets.