Opened 5 years ago

Closed 5 years ago

#17059 closed defect (duplicate)

Tor crashes on FreeBSD

Reported by: yurivict271 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.6.9
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It seems that I didn't do anything but updated OS to latest version, and now it breaks, see the log:

Sep 13 23:19:18.000 [notice] Bootstrapped 0%: Starting
Sep 13 23:19:18.000 [notice] Bootstrapped 0%: Starting
Sep 13 23:19:18.000 [warn] Parse error: too many @last-listed elements.
Sep 13 23:19:18.000 [warn] Parse error: too many @last-listed elements.
Sep 13 23:19:18.000 [warn] Unparseable microdescriptor
Sep 13 23:19:18.000 [warn] Unparseable microdescriptor
Sep 13 23:19:19.000 [err] void tor_assertion_failed_(const char *, unsigned int, const char *, const char *)(): Bug: src/or/routerparse.c:4168: microdescs_parse_from_string: Assertion cp failed; aborting.
Sep 13 23:19:19.000 [err] void tor_assertion_failed_(const char *, unsigned int, const char *, const char *)(): Bug: src/or/routerparse.c:4168: microdescs_parse_from_string: Assertion cp failed; aborting.
Sep 13 23:19:19.000 [err] Bug: Assertion cp failed in microdescs_parse_from_string at src/or/routerparse.c:4168. Stack trace:
Sep 13 23:19:19.000 [err] Bug: Assertion cp failed in microdescs_parse_from_string at src/or/routerparse.c:4168. Stack trace:
Sep 13 23:19:19.000 [err] Bug:     0x1148d67 <tor_assertion_failed_+151> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x1148d67 <tor_assertion_failed_+151> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x10a8aca <microdescs_parse_from_string+2026> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x10a8aca <microdescs_parse_from_string+2026> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105d53e <microdescs_add_to_cache+94> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105d53e <microdescs_add_to_cache+94> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105d475 <microdesc_cache_reload+197> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105d475 <microdesc_cache_reload+197> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105d3a0 <get_microdesc_cache+160> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105d3a0 <get_microdesc_cache+160> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105f564 <update_microdescs_from_networkstatus+36> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105f564 <update_microdescs_from_networkstatus+36> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105fb39 <router_reload_consensus_networkstatus+681> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105fb39 <router_reload_consensus_networkstatus+681> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105843f <do_main_loop+223> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105843f <do_main_loop+223> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105b01f <tor_main+223> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x105b01f <tor_main+223> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x1056af1 <_start+417> at /usr/local/bin/tor
Sep 13 23:19:19.000 [err] Bug:     0x1056af1 <_start+417> at /usr/local/bin/tor

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by gk

Component: - Select a componentTor

comment:2 Changed 5 years ago by cypherpunks

Duplicate of #16400

Tor: 0.2.6.9

Fixed for 0.2.6.10

comment:3 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed

Thanks for tracking it down, cypherpunks!

Note: See TracTickets for help on using tickets.