Opened 4 years ago

Last modified 19 months ago

#17073 new defect

TorButton says Tor is disabled when it's not

Reported by: tamjan Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser Bundle 5.0.2 -- Tor Button 1.9.3.2. On Linux systems:

I use a Tor relay on my local network, to which I connect to through a stunnel (spawned by xinetd on the client side, and spawned by systemd on the server side - where the relay is). I have set a password in the start-tor-browser script, and modified the values as instructed in that script. When I then start Tor, I'm greeted by the "Something Went Wrong!
Tor is not working in this browser." screen, and the Tor button is grayed out. Yet, I can surf to onion sites, and the Tor button shows the Tor circuit for the site I'm on. I assume that at least anonymous surfing is working well, but it's confusing and induces quite a bit of insecurity when the browser reports that it's all disabled.

Child Tickets

Attachments (1)

tor-browser.png (196.3 KB) - added by tamjan 4 years ago.
Screenshot

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by tamjan

Attachment: tor-browser.png added

Screenshot

comment:1 Changed 4 years ago by tamjan

Component: - Select a componentTor Browser
Owner: set to tbb-team

comment:2 Changed 19 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.