Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#17080 closed enhancement (worksforme)

Improve coverage on src/or/main.c (run_scheduled_events)

Reported by: rjunior Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords: testing, 028-triaged
Cc: Actual Points:
Parent ID: Points: small
Reviewer: Sponsor: SponsorS-can

Description

The changes are in the branch "run-scheduled-events"

​​​https://github.com/twstrike/tor_for_patching/tree/run-scheduled-events

Child Tickets

Change History (12)

comment:1 Changed 4 years ago by rjunior

Status: newneeds_review

comment:2 Changed 4 years ago by nickm

Milestone: Tor: 0.2.8.x-final

comment:3 Changed 4 years ago by nickm

Keywords: 028-triaged added

comment:4 Changed 4 years ago by nickm

Sponsor: SponsorS

comment:5 Changed 4 years ago by nickm

Points: small

mark these testing tickets in needs_review as 'small work remaining'

comment:6 Changed 4 years ago by nickm

Status: needs_reviewneeds_revision

Hmmm. Two issues on this one:

  • It adds a huge 'tags' file. That's probably an accident.
  • I want to see how badly this conflicts with the pending #3199; probably a lot, so if we do that one we shouldn't do this one.

comment:7 Changed 3 years ago by nickm

Milestone: Tor: 0.2.8.x-finalTor: 0.2.???

It is impossible that we will fix all 261 currently open 028 tickets before 028 releases. Time to move some out. This is my first pass through the "needs_revision" and "needs_information" tickets, looking for things to move to ???.

Note that in most cases, if these tickets get the requested revisions done in time for the 0.2.8 merge window, they could get considered for review and merge in 0.2.8.

comment:8 Changed 3 years ago by rjunior

Severity: Normal

There's a lot of conflict with HEAD, and I don't have the energy to fix this.

It was intended to improve the coverage of a function with high complexity (run_scheduled_events) in the first place, and I suspect #3199 has addressed the very same issue. I'm OK with closing this unmerged.

comment:9 Changed 3 years ago by nickm

Resolution: worksforme
Status: needs_revisionclosed

ok, thanks for the feedback!

comment:10 Changed 3 years ago by isabela

Sponsor: SponsorSSponsorS-can

comment:11 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:12 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.