Opened 4 years ago

Closed 4 years ago

#17121 closed task (fixed)

Please create a new VM for collector.tp.o

Reported by: karsten Owned by:
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We need to move collector.tp.o away from yatei to a new host, because yatei is slowly dying. I'd say 4G RAM and 150G disk should work for now, assuming we can extend either of the two if we need to. Thanks!

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by qbi

Resolution: fixed
Status: newclosed

@karsten. I created colchicifolium for you. Please check if you are able to log in and use it.

comment:2 Changed 4 years ago by karsten

Resolution: fixed
Status: closedreopened

Yes, I can log in, but I cannot really use it yet. Can you make these changes:

  • install packages: openjdk-7-jdk ant libcommons-codec-java libcommons-compress-java apache2
  • create collector role, if that doesn't exist yet
  • create /srv/collector.torproject.org/ and change its owner to collector:collector
  • create /srv/collector.torproject.org/htdocs/ and make it the document root for https://collector.torproject.org/
  • copy over /etc/apache2/sites-available/collector.torproject.org from yatei and modify as needed
  • allow the karsten user to sudo into collector role on colchicifolium

Or let me know if you'd rather discuss these things on IRC than here. Thanks in advance!

comment:3 Changed 4 years ago by qbi

Resolution: fixed
Status: reopenedclosed

Thanks for the nice description of what you want to change. I did everything on your list and I hope you can use it now.

comment:4 Changed 4 years ago by karsten

Resolution: fixed
Status: closedreopened

Thanks, most things look good, but can you also make the following changes?

  • sudo -l says I can sudo into root and do ALL the things I ever wanted, but that's not what I wanted. ;) Can you change that so that I can do all the things as collector?
  • Please make Java 7 the default, so that java -version says something like java version "1.7.0_79".

Thanks!

comment:5 Changed 4 years ago by qbi

Resolution: fixed
Status: reopenedclosed

Karsten confirmed on IRC that everything is working for him. So I'll finally close the ticket.

Note: See TracTickets for help on using tickets.