Opened 4 years ago

Last modified 3 years ago

#17130 needs_information defect

XML Parsing Error when running Tor Browser the second time

Reported by: ab11936 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: alex@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am using Tor Browser version 5.0.2 (based on Mozilla Firefox 38.2.1)
It is on Windows 8.1 Professional Version 6.3.9600 (Surface)

When I install Tor browser the first time every thing works fine. When I close out of the Tor browser and restart it, it errors every time with the3 following error.

XML Parsing Error: undefined entity
Location: chrome://browser/content/browser.xul
Line Number 1401, Column 11: <toolbarbutton id="PanelUI-quit"


The work around is to reinstall Tor and then it works fine the first time. This happens on version 5.0.3.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by gk

Status: newneeds_information
Version: Tor: unspecified

I am a bit confused by your bug description. Are you saying Tor Browser 5.0.3 solves the problem for you? If not, what are the exact steps to reproduce it?

Last edited 4 years ago by gk (previous) (diff)

comment:2 Changed 4 years ago by ab11936

5.0.3 does not resolve it. I am unsure on how you can repeat it. For me the steps are:

  1. Download and install TBB 5.0.2
  2. Start the browser. Browse internet.
  3. Shutdown TBB.
  4. Restart TBB, this error appears.

My way around this is to repeat step 1. I.e. reinstall TBB and then it works fine. I have searched my hard drive for the file browser.xul I cannot find it. I do not understand what Chorme has to do with TBB. I have Chrome installed, but I normally do not open it.

comment:3 Changed 3 years ago by qbi

Severity: Normal

A similar error was reported at Tor.StackExchange: https://tor.stackexchange.com/q/11920/88
In this case the error message appeared when the user tries to update TBB.

Note: See TracTickets for help on using tickets.