Opened 5 years ago

Closed 5 years ago

#17182 closed defect (not a bug)

keyserver timeout

Reported by: hamsterjovial Owned by: phoul
Priority: Medium Milestone:
Component: User Experience/Tor Support Version:
Severity: Normal Keywords: keyserver timeout
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello,

I am trying to install a Tor node on Ubuntu.

gpg --keyserver keys.gnupg.net --recv 886DDD89

gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

Further install fails accordingly

W: GPG error: :deb.torproject.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 74A941BA219EC810

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by cypherpunks

Component: Tor SupportTor
Severity: Normal

comment:2 Changed 5 years ago by nickm

Component: TorTor Support
Resolution: not a bug
Status: newclosed

No, I think it's tor support. It's no fault of tor if keys.gnupg.net isn't working. In any case, it's not a bug in our software.

(I hear that to get a good default keyserver, you add this to your .gnupg/gpg.conf:

keyserver hkps://hkps.pool.sks-keyservers.net

keyserver-options ca-cert-file=/Users/nickm/.gnupg/sks-keyservers.netCA.pem
keyserver-options no-honor-keyserver-url

).

Please ask help@… for more information if this doesn't resolve your problem. Thanks!

Note: See TracTickets for help on using tickets.