Opened 5 years ago

Closed 12 months ago

#17201 closed defect (duplicate)

Migrate everything from internal SVN

Reported by: nickm Owned by:
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Our internal SVN repo is mostly obsolete, and should get migrated to some combination of git and wiki.

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by nickm

Owner: set to nickm
Status: newassigned

comment:2 Changed 3 years ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:3 Changed 14 months ago by nickm

Owner: nickm deleted

I am not actually working on these tickets, so they shouldn't be assigned to me.

comment:4 Changed 12 months ago by anarcat

in #17202, i documented that there are four SVN repos:

  • corp
  • internal
  • tor
  • vidalia

There I proposed we archive (move away from public view) the latter two and see what breaks, but now I'm thinking they could just be converted into git and shoved on git.tpo.

The former two are more sensitive, because I understand they contain secret stuff. It's unclear to me how to proceed with those. I'd be happy to move them to git as well and make them Secret there, or they could be moved to nextcloud.

What's the plan?

comment:5 Changed 12 months ago by anarcat

Resolution: duplicate
Status: assignedclosed

sigh. it seems this ticket is actually a dupe of #15949, following up there.

Note: See TracTickets for help on using tickets.