Opened 4 years ago

Closed 4 years ago

#17219 closed defect (not a bug)

Tor2Web HS descriptor lookups fail

Reported by: donncha Owned by:
Priority: High Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version: Tor: 0.2.7.3-rc
Severity: Keywords: tor2web
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While testing Tor's Tor2Web mode, all HS descriptor lookup's were failing with a 404 error. It appears that Tor2Web mode tries to make descriptor requests to a HSDirs plaintext Dir port. IIRC in 2013 the HSDir code was modified to only allow descriptor requests over a BEGIN_DIR connection the HSDir OR port.

I'm pretty confused about how this bug could have been present for so long. It seems that nobody actually runs Tor2Web mode. Do the operators of Tor2Web.org use their own patched version of Tor which fixes this bug?

I have a patch for this bug on my Github repo: https://github.com/DonnchaC/tor/tree/tor2web-dir-fix


Child Tickets

Attachments (1)

tor2web-error.log (4.9 KB) - added by donncha 4 years ago.
Tor log of failed HS descriptor fetches

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by donncha

Attachment: tor2web-error.log added

Tor log of failed HS descriptor fetches

comment:1 Changed 4 years ago by donncha

Milestone: Tor: 0.2.8.x-final
Status: newneeds_review

comment:2 Changed 4 years ago by donncha

Looks like I wasn't reading the code carefully enough. I had FascistFirewall enabled which was preventing Tor2Web mode from creating BEGIN_DIR connections to the OR port.

Sorry about the noise :)

comment:3 Changed 4 years ago by donncha

Resolution: not a bug
Status: needs_reviewclosed
Note: See TracTickets for help on using tickets.