Opened 3 years ago

Closed 3 years ago

#17223 closed defect (fixed)

tortls.c compile errors on git master/current

Reported by: yancm Owned by: yawning
Priority: Medium Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Keywords: tor-core, 028-triaged, openssl-1.1
Cc: Actual Points:
Parent ID: Points: small
Reviewer: Sponsor:

Description

Hi,

On NetBSD 6_Stable (i386) compiling against openssl git master/current,
I have been receiving the following errors for a couple of days:

CC src/common/tortls.o

In file included from src/common/tortls.c:75:0:
src/common/tortls.h:139:15: error: conflicting types for 'SSL_SESSION_get_master_key'
/usr/local/ssl/include/openssl/ssl.h:1658:15: note: previous declaration of 'SSL_SESSION_get_master_key' was here
src/common/tortls.c: In function 'log_cert_lifetime':
src/common/tortls.c:2139:3: warning: passing argument 1 of 'X509_get_notBefore' discards qualifiers from pointer target type
/usr/local/ssl/include/openssl/x509.h:694:13: note: expected 'struct X509 *' but argument is of type 'const struct X509 *'
src/common/tortls.c:2147:3: warning: passing argument 1 of 'X509_get_notAfter' discards qualifiers from pointer target type
/usr/local/ssl/include/openssl/x509.h:696:12: note: expected 'struct X509 *' but argument is of type 'const struct X509 *'
src/common/tortls.c: In function 'check_cert_lifetime_internal':
src/common/tortls.c:2309:3: warning: passing argument 1 of 'X509_get_notBefore' discards qualifiers from pointer target type
/usr/local/ssl/include/openssl/x509.h:694:13: note: expected 'struct X509 *' but argument is of type 'const struct X509 *'
src/common/tortls.c:2314:3: warning: passing argument 1 of 'X509_get_notAfter' discards qualifiers from pointer target type
/usr/local/ssl/include/openssl/x509.h:696:12: note: expected 'struct X509 *' but argument is of type 'const struct X509 *'
src/common/tortls.c: At top level:
src/common/tortls.h:139:15: warning: 'SSL_SESSION_get_master_key' used but never defined
Makefile:3222: recipe for target 'src/common/tortls.o' failed
gmake[1]: * [src/common/tortls.o] Error 1
gmake[1]: Leaving directory '/usr/local/src/tor'
Makefile:1855: recipe for target 'all' failed
gmake:
* [all] Error 2

I understand maintaining sync (tor/openssl - master branches) is not the
primary concern of the effort, but thought I would bring this to your attention.

--gene

Child Tickets

Change History (6)

comment:1 Changed 3 years ago by yawning

Keywords: tor-core 028-triaged openssl added
Milestone: Tor: 0.2.8.x-final
Owner: set to yawning
Points: small
Status: newassigned

Triaging and accepting, since nick's busy and I was the other person to last handle this.

comment:2 Changed 3 years ago by nickm

Keywords: netbsd6 added

What version of openssl does this have?

comment:3 Changed 3 years ago by yancm

This is built against (trying to build against) the OpenSSL 1.1.0-dev sources. Basically the OpenSSL git master branch.

comment:4 Changed 3 years ago by nickm

Hm. If it worked with the old openssl but not the new one, maybe this is a regression, and the x509_get_not{Before,After} functions should take a const argument. Could somebody please ask the openssl devs?

comment:5 Changed 3 years ago by nickm

Keywords: openssl-1.1 added; openssl netbsd6 removed

comment:6 Changed 3 years ago by rl1987

Resolution: fixed
Status: assignedclosed

Fixed in b216340d75403571b8031baf5f63f751584470d1 and 1eb838b30361b0dcc1e2b82815be25391d5a15f1 .

Note: See TracTickets for help on using tickets.